diff mbox series

[bug#37598,4/4] gnu: Add python-cookiecutter.

Message ID 20191004072436.oub2epgpjiugy7nu@rafflesia
State Accepted
Headers show
Series None | expand

Commit Message

Tanguy LE CARROUR Oct. 4, 2019, 7:24 a.m. UTC
From ef47c7b065efa56c773ed66eff92984b15a4b6fd Mon Sep 17 00:00:00 2001
From: "tanguy@bioneland.org" <tanguy@bioneland.org>
Date: Thu, 3 Oct 2019 09:23:24 +0200
Subject: [PATCH 4/4] gnu: Add python-cookiecutter.

---
 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd3a3e6c99..9cdd1f2e70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9130,6 +9130,41 @@  server with very acceptable performance.")
      "This package provides cross-platform cross-python shutil.which functionality.")
     (license license:bsd-3)))
 
+(define-public python-cookiecutter
+  (package
+    (name "python-cookiecutter")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cookiecutter" version))
+       (sha256
+        (base32
+         "0glsvaz8igi2wy1hsnhm9fkn6560vdvdixzvkq6dn20z3hpaa5hk"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-freezegun" ,python-freezegun)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-catchlog" ,python-pytest-catchlog)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-mock" ,python-pytest-mock)))
+    (propagated-inputs
+     `(("python-binaryornot" ,python-binaryornot)
+       ("python-click" ,python-click)
+       ("python-future" ,python-future)
+       ("python-jinja2" ,python-jinja2)
+       ("python-jinja2-time" ,python-jinja2-time)
+       ("python-poyo" ,python-poyo)
+       ("python-requests" ,python-requests)
+       ("python-whichcraft" ,python-whichcraft)))
+    (home-page
+     "https://github.com/audreyr/cookiecutter")
+    (synopsis
+     "Command-line utility that creates projects from project templates")
+    (description "A command-line utility that creates projects from project templates,
+e.g. creating a Python package project from a Python package project template.")
+    (license license:bsd-3)))
+
 (define-public python-pyquery
   (package
     (name "python-pyquery")