diff mbox series

[bug#37598,1/4] gnu: Add python-jinja2-time.

Message ID 20191004072040.fpwcb2lmeih2mvsv@rafflesia
State Accepted
Headers show
Series [bug#37598,1/4] gnu: Add python-jinja2-time. | expand

Commit Message

Tanguy LE CARROUR Oct. 4, 2019, 7:20 a.m. UTC
From 4a36e29b417f5a3ca109f3148d8352f6177dc52d Mon Sep 17 00:00:00 2001
From: "tanguy@bioneland.org" <tanguy@bioneland.org>
Date: Thu, 3 Oct 2019 09:05:26 +0200
Subject: [PATCH 1/4] gnu: Add python-jinja2-time.

---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Mathieu Othacehe Oct. 4, 2019, 7:50 a.m. UTC | #1
Hello Tanguy,

Thanks for your patches. A few remarks (more details at
https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html):

> Subject: [PATCH 1/4] gnu: Add python-jinja2-time.
>

You need to add a commit message, compliant with ChangeLog format. You
can find examples in commit history.

> +    (description
> +     "Jinja2 Extension for Dates and Times")

Description should follow the rules dictated at
https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions,
most specifically "Descriptions should take between five and ten
lines. Use full sentences, and avoid using acronyms without first
introducing them".

Otherwise, your serie seems fine :)

Thanks,

Mathieu
Ludovic Courtès Oct. 13, 2019, 10:02 p.m. UTC | #2
Hi Tanguy,

Did you have a chance to look into Mathieu’s suggestions (below)?

We’re almost there so let’s make sure we don’t forget about this patch
series!

Thanks in advance,
Ludo’.

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> Hello Tanguy,
>
> Thanks for your patches. A few remarks (more details at
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html):
>
>> Subject: [PATCH 1/4] gnu: Add python-jinja2-time.
>>
>
> You need to add a commit message, compliant with ChangeLog format. You
> can find examples in commit history.
>
>> +    (description
>> +     "Jinja2 Extension for Dates and Times")
>
> Description should follow the rules dictated at
> https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions,
> most specifically "Descriptions should take between five and ten
> lines. Use full sentences, and avoid using acronyms without first
> introducing them".
>
> Otherwise, your serie seems fine :)
>
> Thanks,
>
> Mathieu
Tanguy LE CARROUR Oct. 14, 2019, 7:09 a.m. UTC | #3
Hi Ludovic, Hi Mathieu!


Le 10/14, Ludovic Courtès a écrit :
> Did you have a chance to look into Mathieu’s suggestions (below)?

No!… because I don't get notifications when someone sends a comment on a
bug I opened! :-(
I have to go and check the 2 others I opened, I guess! I hope I didn't
seem to give up on them!


> Mathieu Othacehe <m.othacehe@gmail.com> skribis:
> > Hello Tanguy,

Sorry for not answering! And thanks for the time you spent into
reviewing my patches!


> > Thanks for your patches. A few remarks (more details at
> > https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html):
> >
> >> Subject: [PATCH 1/4] gnu: Add python-jinja2-time.
> >
> > You need to add a commit message, compliant with ChangeLog format. You
> > can find examples in commit history.

I have to confess that I am… a minimalist! :-)
I thought that `gnu: Add python-jinja2-time.` would be enough and I didn't have
to go into more details about the "why"!
Please believe me when I say that it was not out of laziness.
I'll go dig into commit messages and see what I have to add.


> >> +    (description
> >> +     "Jinja2 Extension for Dates and Times")
> >
> > Description should follow the rules dictated at
> > https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions,
> > most specifically "Descriptions should take between five and ten
> > lines. Use full sentences, and avoid using acronyms without first
> > introducing them".

OK, this one was pure laziness! So far, I've never modified description/synopsis
provided by `guix import`.
I guess, now that I'm more comfortable with the process, I can focus more on
"what" I am submitting and less on "how" I am submitting it!

Thanks again guys for your time. I'll fix the patches and resubmit them as
soon as I can!
Ludovic Courtès Oct. 14, 2019, 8:25 p.m. UTC | #4
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

> Thanks again guys for your time. I'll fix the patches and resubmit them as
> soon as I can!

Alright, thank you!  :-)

Ludo’.
Mathieu Othacehe Oct. 15, 2019, 12:28 p.m. UTC | #5
Hello Tanguy,

> Thanks again guys for your time. I'll fix the patches and resubmit them as
> soon as I can!

I pushed this serie with a few adjustments to description fields.

Thanks,

Mathieu
Tanguy LE CARROUR Oct. 15, 2019, 1:14 p.m. UTC | #6
Le 10/15, Mathieu Othacehe a écrit :
> I pushed this serie with a few adjustments to description fields.

Thanks! Can't wait to see the adjustments! :-) So many things I still
have to learn!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 413d68c258..6309ac4b8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -66,6 +66,7 @@ 
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2475,6 +2476,28 @@  written in pure Python.")
 (define-public python2-jinja2
   (package-with-python2 python-jinja2))
 
+(define-public python-jinja2-time
+  (package
+    (name "python-jinja2-time")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jinja2-time" version))
+       (sha256
+        (base32
+         "0h0dr7cfpjnjj8bgl2vk9063a53649pn37wnlkd8hxjy656slkni"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-arrow" ,python-arrow)
+       ("python-jinja2" ,python-jinja2)))
+    (home-page
+     "https://github.com/hackebrot/jinja2-time")
+    (synopsis "Jinja2 Extension for Dates and Times")
+    (description
+     "Jinja2 Extension for Dates and Times")
+    (license license:expat)))
+
 (define-public python-pystache
   (package
     (name "python-pystache")