diff mbox series

[bug#37613,1/1] gnu: Add python-httpie.

Message ID 20191004065735.iy7j2at3h2l4cej7@rafflesia
State Accepted
Headers show
Series gnu: Add python-httpie. | expand

Commit Message

Tanguy LE CARROUR Oct. 4, 2019, 6:57 a.m. UTC
From 8a60be6eb9ee4e17dc4fbc19ada22c7993841b26 Mon Sep 17 00:00:00 2001
From: "tanguy@bioneland.org" <tanguy@bioneland.org>
Date: Fri, 4 Oct 2019 08:44:59 +0200
Subject: [PATCH] gnu: Add python-httpie.

---
 gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e37ae94e18..b7d3b0aa73 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,6 +30,7 @@ 
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -303,6 +304,32 @@  other HTTP libraries.")
 (define-public python2-httplib2
   (package-with-python2 python-httplib2))
 
+(define-public python-httpie
+  (package
+    (name "python-httpie")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "httpie" version))
+       (sha256
+        (base32
+         "103fcigpxf4nqmrdqjnyz7d9n4n16906slwmmqqc0gkxv8hnw6vd"))))
+    (build-system python-build-system)
+    (arguments
+     ;; The tests attempt to access external web servers, so we cannot run them.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-pygments" ,python-pygments)
+       ("python-requests" ,python-requests)))
+    (home-page "http://httpie.org/")
+    (synopsis
+     "HTTPie - a CLI, cURL-like tool for humans")
+    (description
+     "HTTPie - a CLI, cURL-like tool for humans.")
+    (license license:bsd-3)))
+
 (define-public python-html2text
   (package
     (name "python-html2text")