diff mbox series

[bug#37602] gnu: Add r-oai.

Message ID 20191003135130.12579-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#37602] gnu: Add r-oai. | expand

Commit Message

Wiktor Żelazny Oct. 3, 2019, 1:51 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-oai): new variable.
---
 gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Marius Bakke March 21, 2020, 8:18 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-oai): new variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3a9a605efe..479f5f4e46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15637,3 +15637,29 @@  unique identifiers, and whether it is a certain length.  In addition,
 files and to efficiently import multiple tabular data files into one
 data.table.")
     (license license:gpl3)))
+
+(define-public r-oai
+  (package
+     (name "r-oai")
+     (version "0.3.0")
+     (source (origin
+       (method url-fetch)
+       (uri (cran-uri "oai" version))
+       (sha256
+         (base32
+           "1ipw9bq3ra66d1ddj1rylyyd20mlcb2i7phzhywra53s1fdifq1g"))))
+     (build-system r-build-system)
+     (propagated-inputs
+       `(("r-xml2" ,r-xml2)
+         ("r-httr" ,r-httr)
+         ("r-plyr" ,r-plyr)
+         ("r-stringr" ,r-stringr)
+         ("r-tibble" ,r-tibble)))
+     (home-page "https://github.com/ropensci/oai/")
+     (synopsis "General purpose OAI-PMH services client")
+     (description "@code{oai} provides a general purpose client to work with
+any @dfn{Open Archives Initiative Protocol for 'Metadata' Harvesting} (OAI-PMH)
+service.  Functions are provided to work with the OAI-PMH verbs:
+@code{GetRecord}, @code{Identify}, @code{ListIdentifiers},
+@code{ListMetadataFormats}, @code{ListRecords}, and @code{ListSets}.")
+     (license license:expat)))