diff mbox series

[bug#37600] gnu: Add r-httpcode.

Message ID 20191003134637.7040-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#37600] gnu: Add r-httpcode. | expand

Commit Message

Wiktor Żelazny Oct. 3, 2019, 1:46 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-httpcode): New variable.
---
 gnu/packages/cran.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Marius Bakke March 21, 2020, 8:12 p.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-httpcode): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3a9a605efe..8d94047475 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15637,3 +15637,22 @@  unique identifiers, and whether it is a certain length.  In addition,
 files and to efficiently import multiple tabular data files into one
 data.table.")
     (license license:gpl3)))
+
+(define-public r-httpcode
+  (package
+     (name "r-httpcode")
+     (version "0.2.0")
+     (source (origin
+       (method url-fetch)
+       (uri (cran-uri "httpcode" version))
+       (sha256
+         (base32
+           "06k853ihwzkcx4z3jzazpb03p91frqkwz18jy4fwr8j2nwyqbhgv"))))
+     (build-system r-build-system)
+     (home-page "https://github.com/sckott/httpcode")
+     (synopsis "HTTP status code helper")
+     (description "@code{httpcode} provides functionality for finding and
+explaining the meaning of @code{HTTP} status codes.  Functions are included for
+searching for codes by full or partial number, by message, and to get
+appropriate dog and cat images for many status codes.")
+     (license license:expat)))