diff mbox series

[bug#37444,v4,20/24] added go package go-git-sr-ht-sircmpwn-pty

Message ID 20191001213726.21676-20-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#37444,v4,01/24] added go package go-golang-org-x-oauth2 | expand

Commit Message

Martin Becze Oct. 1, 2019, 9:37 p.m. UTC
* gnu/packages/golang.scm (go-git-sr-ht-sircmpwn-pty): added package
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb85c4f5b7..b925f5df95 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4189,3 +4189,27 @@  quoting, commenting, and escaping.")
      (description "A POSIX-compatible getopt implementation for Go, because
  POSIX getopt is The Correct Way to interpret arguments to command line utilities.")
      (license license:expat))))
+
+(define-public go-git-sr-ht-sircmpwn-pty
+  (let ((commit "3a43678975a9cb13dbcf05ea7a1611ebce3eadb2")
+        (url "https://git.sr.ht/~sircmpwn/pty"))
+    (package
+     (name "go-git-sr-ht-sircmpwn-pty")
+     (version (git-version "0.0.0" "0" commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url url)
+             (commit commit)))
+       (sha256
+        (base32
+         "1spa779vb2j1vgwm1cpbmf7f8wj6zwyyy49ihz134izvah7vncsw"))
+       (file-name (git-file-name name version))))
+     (build-system go-build-system)
+     (arguments
+      '(#:import-path "git.sr.ht/~sircmpwn/pty"))
+     (home-page url)
+     (synopsis "A Go package for using unix pseudo-terminals")
+     (description "Pty is a Go package for using unix pseudo-terminals.")
+     (license license:expat))))