diff mbox series

[bug#37444,v3,16/23] added go package go-github-com-miolini-datacounter

Message ID 20190926152118.8073-16-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#37444,v3,01/23] added go package go-github-com-mattn-go-pointer | expand

Commit Message

Martin Becze Sept. 26, 2019, 3:21 p.m. UTC
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 487a963ff0..bb00230b60 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4113,3 +4113,27 @@  quoting, commenting, and escaping.")
      (description "Implements Base36 encoding and decoding, which is useful to
  represent large integers in a case-insensitive alphanumeric way.")
      (license license:expat))))
+
+(define-public go-github-com-miolini-datacounter
+  (let ((url "https://github.com/miolini/datacounter")
+        (commit "aa48df3a02c1fbcd3040271f631887991c3071fb"))
+    (package
+     (name "go-github-com-miolini-datacounter")
+     (version (git-version "0.0.0" "0" commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url url)
+             (commit commit)))
+       (sha256
+        (base32
+         "12ldh5jhafjhh3jvh979mldwygkkcnm97axs7dhlai6gqwlhls87"))
+       (file-name (git-file-name name version))))
+     (build-system go-build-system)
+     (arguments
+      '(#:import-path "github.com/miolini/datacounter"))
+     (home-page url)
+     (synopsis "Golang counters for readers/writers")
+     (description "Golang counters for readers/writers")
+     (license license:expat))))