diff mbox series

[bug#37519,v2] gnu: add iwd.

Message ID 20190926142340.29343-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#37519,v2] gnu: add iwd. | expand

Commit Message

Brice Waegeneire Sept. 26, 2019, 2:23 p.m. UTC
* gnu/packages/networking.scm (iwd): New variable.
---
This version of the patch split the commit in two, remove the commented
code and replace the patch with a post-unpack phase.

 gnu/packages/networking.scm | 56 +++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)

Comments

Ludovic Courtès Sept. 26, 2019, 9:05 p.m. UTC | #1
Hi Brice,

Brice Waegeneire <brice@waegenei.re> skribis:

> * gnu/packages/networking.scm (iwd): New variable.
> ---
> This version of the patch split the commit in two, remove the commented
> code and replace the patch with a post-unpack phase.

This patch looks good, but could you also resend the ell patch?

Thanks in advance,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6bdf7f9e2f..87dd015320 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -30,6 +30,7 @@ 
 ;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2578,3 +2579,58 @@  communication.")
     (description "FRRouting (FRR) is an IP routing protocol suite which includes
 protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
     (license license:gpl2+)))
+
+(define-public iwd
+  (package
+    (name "iwd")
+    (version "0.21")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.kernel.org/pub/scm/network/wireless/iwd.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "001dikinsa6kshwscjbvwipavzwpqnpvx9fpshcn63gbvbhyd393"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("dbus" ,dbus)
+       ("libtool" ,libtool)
+       ("ell" ,ell)
+       ("readline" ,readline)))
+    (native-inputs
+     `(("asciidoc" ,asciidoc)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkgconfig" ,pkg-config)
+       ("python" ,python)
+       ("openssl" ,openssl)))
+    (arguments
+     `(#:configure-flags
+       (let ((dbus (assoc-ref %outputs "out")))
+         (list "--disable-systemd-service"
+               "--enable-external-ell"
+               "--enable-hwsim"
+               "--enable-tools"
+               "--enable-wired"
+               "--enable-docs"
+               "--localstatedir=/var"
+               (string-append "--with-dbus-datadir=" dbus "/share/")
+               (string-append "--with-dbus-busdir="
+                              dbus "/share/dbus-1/system-services")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'pre-configure
+           (lambda _
+             ;; Don't try to 'mkdir /var'.
+             (substitute* "Makefile.in"
+               (("\\$\\(MKDIR_P\\) -m 700")
+                "true")))))))
+    (home-page "https://git.kernel.org/cgit/network/wireless/iwd.git/")
+    (synopsis "Internet Wireless Daemon")
+    (description "iwd is a wireless daemon for Linux written by Intel that
+aims to replace WPA supplicant. It optimize resource utilization by not
+depending on any external libraries and instead utilizing features provided by
+the Linux Kernel to the maximum extent possible.")
+    (license license:lgpl2.1+)))