diff mbox series

[bug#37511] gnu: Add ccls.

Message ID 20190925105224.3683-1-m.othacehe@gmail.com
State Accepted
Headers show
Series [bug#37511] gnu: Add ccls. | expand

Commit Message

Mathieu Othacehe Sept. 25, 2019, 10:52 a.m. UTC
* gnu/packages/cpp.scm (ccls): New variable.
---
 gnu/packages/cpp.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Sept. 26, 2019, 9:32 a.m. UTC | #1
Hi,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> * gnu/packages/cpp.scm (ccls): New variable.

[...]

> +    (home-page "https://github.com/MaskRay/ccls")
> +    (synopsis "C/C++/Objective-C language server")
> +    (description
> +     "C/C++/Objective-C language server supporting cross references,
> +hierarchies, completion and syntax highlighting.")

Could you write a full sentence and ideally elaborate a little bit?

Otherwise LGTM!

Thanks,
Ludo’.
Mathieu Othacehe Sept. 26, 2019, 11:55 a.m. UTC | #2
Hey,

> Could you write a full sentence and ideally elaborate a little bit?

Fixed and pushed on core-updates as it needs gcc7.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9e95bacd65..277274e60f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,7 +34,8 @@ 
   #:use-module (gnu packages compression)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages tls))
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages web))
 
 (define-public libzen
   (package
@@ -276,3 +278,31 @@  intuitive syntax and trivial integration.")
     (description "xtl is a C++ header-only template library providing basic
 tools (containers, algorithms) used by other QuantStack packages.")
     (license license:bsd-3)))
+
+(define-public ccls
+  (package
+    (name "ccls")
+    (version "0.20190823.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MaskRay/ccls")
+             (commit version)))
+       (sha256
+        (base32 "1sx31zp6q2qc6fz3r78rx34zp2x4blrqzxwbpww71vb6lp1clmdm"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ; no check target.
+    (inputs
+     `(("rapidjson" ,rapidjson)))
+    (native-inputs
+     `(("clang" ,clang)
+       ("llvm" ,llvm)))
+    (home-page "https://github.com/MaskRay/ccls")
+    (synopsis "C/C++/Objective-C language server")
+    (description
+     "C/C++/Objective-C language server supporting cross references,
+hierarchies, completion and syntax highlighting.")
+    (license license:asl2.0)))