diff mbox series

[bug#37413,v2,11/11] DRAFT etc: Add channel news file.

Message ID 20190921211228.13096-12-ludo@gnu.org
State Accepted
Headers show
Series Channel news distribution mechanism | expand

Commit Message

Ludovic Courtès Sept. 21, 2019, 9:12 p.m. UTC
DRAFT: Update commit ID before pushing.

* etc/news.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
---
 Makefile.am  |  1 +
 etc/news.scm | 23 +++++++++++++++++++++++
 2 files changed, 24 insertions(+)
 create mode 100644 etc/news.scm

Comments

pelzflorian (Florian Pelz) Sept. 22, 2019, 11:14 a.m. UTC | #1
I can only make comments about the text. :D

Patch 1:

On Sat, Sep 21, 2019 at 11:12:18PM +0200, Ludovic Courtès wrote:
> +(define (display-channel-news profile)
> +  "Display new about the channels of PROFILE "

You fixed it in patch 8 anyway, so you can ignore it: Docstring should
be "Display news…" with s.

Patch 4:

On Sat, Sep 21, 2019 at 11:12:21PM +0200, Ludovic Courtès wrote:
> +The @code{title} field should be a one-line summary while @code{body}
> +can be arbitrary long, and both can contain Texinfo markup
> +(@pxref{Overview,,, texinfo, GNU Texinfo}).  Both the title and body are
> +a list of language tag/message tuples, which allows @command{guix pull}
> +to display news in the language that corresponds to the user's locale.

“arbitrarily” with -ly.

Patch 11:

On Sat, Sep 21, 2019 at 11:12:28PM +0200, Ludovic Courtès wrote:
> +(channel-news
> + (version 0)
> + (entry (commit "d17f14c167791b640e49b2b6443d20f9534c62d7")
> +        (title (en "New channel news mechanism")
> +               (fr "Nouveau mécanisme d'information sur les canaux"))

German would be:

(de "Neuer Mechanismus, um Neuigkeiten über Kanäle anzuzeigen.")



> +        (body
> +         (en "You are reading this message through the new channel news
> +mechanism, congratulations!  This mechanism allows channel authors to provide
> +@dfn{news entries} that their users can view with @command{guix pull --news}.
> +Run @command{info \"(guix) Invoking guix pull\"} for more info.")
> +         (fr "Ce message t'arrive à travers le nouveau mécanisme d'information
> +des canaux, bravo !  Ce mécanisme permet aux auteur·rice·s de canaux de
> +fournir des informations qu'on peut visualiser avec @command{guix pull
> +--news}.  Tape @command{info \"(guix.fr) Invoquer guix pull\"} pour plus de
> +détails."))))

German would be:

(de "Sie lesen diese Meldung mit Hilfe des neuen Mechanismus, um
Neuigkeiten über Kanäle anzuzeigen — Glückwunsch! Mit diesem
Mechanismus können Kanalautoren Ihren Nutzern @dfn{Einträge zu
Neuigkeiten} mitteilen, die diese sich mit @command{guix pull --news}
anzeigen lassen können. Führen Sie @command{info \"(guix.de) Aufruf
von guix pull\"} aus, um weitere Informationen zu erhalten.")

(Of course the German manual does not actually contain translated
information yet, but whatever.  It would be nice if the Translation
Project would accept new PO files without marking PO entries as fuzzy
that changed since the old version at the TP.)

Regards,
Florian
Ludovic Courtès Sept. 23, 2019, 9:13 a.m. UTC | #2
Hi Florian,

Thanks for these comments!  I’ve fixed the issues you reported and push
the result as 90ca791ab082f0513cd5e8af7acfd8db63a6e73a.

So hopefully, next time you pull, ‘guix pull --news’ will show you the
very first news.

I’ve also created the guix-i18n@gnu.org alias (Cc’d), where I added
yourself, Julien, Miguel, Meiyo, and znavko (see
<https://issues.guix.gnu.org/issue/37413> for context.)

This alias should be low-traffic (one translation request per month
maybe?), but please let me know if you do not want to be there.

Florian, note that I’m still open to a PO-based translation workflow.  I
prefer to leave it to you translators to see whether/how this could be
set up, as discussed earlier.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index 3c27d8ee10..6a4cfcd4a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -536,6 +536,7 @@  EXTRA_DIST +=						\
   .guix-channel						\
   scripts/guix.in					\
   etc/guix-install.sh					\
+  etc/news.scm						\
   build-aux/build-self.scm				\
   build-aux/compile-all.scm				\
   build-aux/hydra/evaluate.scm				\
diff --git a/etc/news.scm b/etc/news.scm
new file mode 100644
index 0000000000..05241b36e7
--- /dev/null
+++ b/etc/news.scm
@@ -0,0 +1,23 @@ 
+;; GNU Guix news, for use by 'guix pull'.
+;;
+;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;
+;; Copying and distribution of this file, with or without modification, are
+;; permitted in any medium without royalty provided the copyright notice and
+;; this notice are preserved.
+
+(channel-news
+ (version 0)
+ (entry (commit "d17f14c167791b640e49b2b6443d20f9534c62d7")
+        (title (en "New channel news mechanism")
+               (fr "Nouveau mécanisme d'information sur les canaux"))
+        (body
+         (en "You are reading this message through the new channel news
+mechanism, congratulations!  This mechanism allows channel authors to provide
+@dfn{news entries} that their users can view with @command{guix pull --news}.
+Run @command{info \"(guix) Invoking guix pull\"} for more info.")
+         (fr "Ce message t'arrive à travers le nouveau mécanisme d'information
+des canaux, bravo !  Ce mécanisme permet aux auteur·rice·s de canaux de
+fournir des informations qu'on peut visualiser avec @command{guix pull
+--news}.  Tape @command{info \"(guix.fr) Invoquer guix pull\"} pour plus de
+détails."))))