diff mbox series

[bug#37442] import/github: Check for more version prefixes

Message ID 20190917185915.GA6057@E5400
State Accepted
Headers show
Series [bug#37442] import/github: Check for more version prefixes | expand

Commit Message

Efraim Flashner Sept. 17, 2019, 6:59 p.m. UTC
'guix refresh openjpeg'
gnu/packages/image.scm:762:13: openjpeg would be upgraded from 2.3.1 to ersion.2.1

I checked the git repository, there are a number of tags reading
'version.2.1' or similar. This allows for version tags 'version2.1' or
'version-2.1' or 'version.2.1' or 'version→2.1'. (still looking for a
repo to test the last one)

Comments

Ludovic Courtès Sept. 19, 2019, 7:50 p.m. UTC | #1
Hi!

Efraim Flashner <efraim@flashner.co.il> skribis:

> 'guix refresh openjpeg'
> gnu/packages/image.scm:762:13: openjpeg would be upgraded from 2.3.1 to ersion.2.1

Ouch.

> I checked the git repository, there are a number of tags reading
> 'version.2.1' or similar. This allows for version tags 'version2.1' or
> 'version-2.1' or 'version.2.1' or 'version→2.1'. (still looking for a
> repo to test the last one)

:-)

> From 1d32a908d3bdbec89420b638791960e7535a5e90 Mon Sep 17 00:00:00 2001
> From: Efraim Flashner <efraim@flashner.co.il>
> Date: Tue, 17 Sep 2019 21:50:36 +0300
> Subject: [PATCH] import/github: Check for more version prefixes.
>
> * guix/import/github.scm (latest-released-version): Allow the
> version string to begin with the word 'version'.

LGTM!

Thanks,
Ludo’.
Efraim Flashner Sept. 20, 2019, 6:07 a.m. UTC | #2
Thanks. Patch pushed.
diff mbox series

Patch

diff --git a/guix/import/github.scm b/guix/import/github.scm
index 55ea00a111..df5f6ff32f 100644
--- a/guix/import/github.scm
+++ b/guix/import/github.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -186,7 +187,12 @@  the package e.g. 'bedtools2'.  Return #f if there is no releases"
                        (substring tag 0 (+ name-length 1))))
         (substring tag (+ name-length 1)))
        ;; some tags start with a "v" e.g. "v0.25.0"
+       ;; or with the word "version" e.g. "version.2.1"
        ;; where some are just the version number
+       ((string-prefix? "version" tag)
+        (if (char-set-contains? char-set:digit (string-ref tag 7))
+            (substring tag 7)
+            (substring tag 8)))
        ((string-prefix? "v" tag)
         (substring tag 1))
        ;; Finally, reject tags that don't start with a digit: