diff mbox series

[bug#37434,1/2] gnu: ghc-megaparsec: Update to 7.0.5.

Message ID 20190917033730.28806-1-ericbavier@centurylink.net
State Accepted
Headers show
Series [bug#37434,1/2] gnu: ghc-megaparsec: Update to 7.0.5. | expand

Commit Message

Eric Bavier Sept. 17, 2019, 3:37 a.m. UTC
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/haskell.scm (ghc-megaparsec): Update to 7.0.5
[arguments]: Remove field.
---
 gnu/packages/haskell.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Sept. 20, 2019, 8:32 p.m. UTC | #1
Hi Eric,

ericbavier@centurylink.net skribis:

> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/haskell.scm (ghc-megaparsec): Update to 7.0.5
> [arguments]: Remove field.

Since <https://www.stackage.org/lts-14.6> lists megaparsec 7.0.5, I
think this is OK.  Am I right, Timothy?

Thanks,
Ludo’.
Timothy Sample Sept. 20, 2019, 10:21 p.m. UTC | #2
Hi Ludo and Eric,

Ludovic Courtès <ludo@gnu.org> writes:

> ericbavier@centurylink.net skribis:
>
>> From: Eric Bavier <bavier@member.fsf.org>
>>
>> * gnu/packages/haskell.scm (ghc-megaparsec): Update to 7.0.5
>> [arguments]: Remove field.
>
> Since <https://www.stackage.org/lts-14.6> lists megaparsec 7.0.5, I
> think this is OK.  Am I right, Timothy?

No!  :)

Stackage LTS 14 targets GHC 8.6, which we are not (yet) using for
Haskell builds.  We still use GHC 8.4, so we follow Stackage LTS 12
(<https://www.stackage.org/lts-12>), which lists megaparsec at 1.0.0.


-- Tim
Timothy Sample Sept. 20, 2019, 10:25 p.m. UTC | #3
Timothy Sample <samplet@ngyro.com> writes:

> Stackage LTS 14 targets GHC 8.6, which we are not (yet) using for
> Haskell builds.  We still use GHC 8.4, so we follow Stackage LTS 12
> (<https://www.stackage.org/lts-12>), which lists megaparsec at 1.0.0.

That should 6.5.0.  Sorry!  I was looking at hspec-megaparsec.


-- Tim
Ludovic Courtès Sept. 23, 2019, 8:25 a.m. UTC | #4
Hello!

Timothy Sample <samplet@ngyro.com> skribis:

> Timothy Sample <samplet@ngyro.com> writes:
>
>> Stackage LTS 14 targets GHC 8.6, which we are not (yet) using for
>> Haskell builds.  We still use GHC 8.4, so we follow Stackage LTS 12
>> (<https://www.stackage.org/lts-12>), which lists megaparsec at 1.0.0.
>
> That should 6.5.0.

OK, got it—I had “LTS” right but the number wrong, which is
unfortunate.  :-)

Eric, could you adjust accordingly?

Thanks,
Ludo’.
Eric Bavier Sept. 24, 2019, 1:59 a.m. UTC | #5
Idris 1.3.2 unfortunately needs megaparsec>=7.0.4.

FWIW, idris is our only package that depends on ghc-megaparsec. :)  So maybe an upgrade is fine?

I was under the impression that our 'guix refresh' updater was supposed to use the appropriate stackage version?  But it seems to be referencing version 14.6.


----- On Sep 23, 2019, at 3:25 AM, Ludovic Courtès ludo@gnu.org wrote:

> Hello!
> 
> Timothy Sample <samplet@ngyro.com> skribis:
> 
>> Timothy Sample <samplet@ngyro.com> writes:
>>
>>> Stackage LTS 14 targets GHC 8.6, which we are not (yet) using for
>>> Haskell builds.  We still use GHC 8.4, so we follow Stackage LTS 12
>>> (<https://www.stackage.org/lts-12>), which lists megaparsec at 1.0.0.
>>
>> That should 6.5.0.
> 
> OK, got it—I had “LTS” right but the number wrong, which is
> unfortunate.  :-)
> 
> Eric, could you adjust accordingly?
> 
> Thanks,
> Ludo’.
Ludovic Courtès Sept. 24, 2019, 7:16 a.m. UTC | #6
Hello,

Eric Bavier <ericbavier@centurylink.net> skribis:

> Idris 1.3.2 unfortunately needs megaparsec>=7.0.4.
>
> FWIW, idris is our only package that depends on ghc-megaparsec. :)  So maybe an upgrade is fine?

For the sake of consistency, what about adding a variant of megaparsec
for use by Idris, and keeping the LTS-12 version?

> I was under the impression that our 'guix refresh' updater was supposed to use the appropriate stackage version?  But it seems to be referencing version 14.6.

Looking at ‘latest-lts-release’ in (guix import stackage), the updater
seems to just take the latest LTS version.

We should probably fix that by having the argument to
‘stackage-lts-info-fetch’ default to the currently targeted LTS version.
Otherwise one has to know the LTS version and pass it to ‘guix import
stackage --lts-version’, which is error-prone.

Thoughts?

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8787f10789..960068ab23 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4050,7 +4050,7 @@  combinators.")
 (define-public ghc-megaparsec
   (package
     (name "ghc-megaparsec")
-    (version "6.5.0")
+    (version "7.0.5")
     (source
      (origin
        (method url-fetch)
@@ -4059,11 +4059,8 @@  combinators.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "12iggy7qpf8x93jm64zf0g215xwy779bqyfyjk2bhmxqqr1yzgdy"))))
+         "0bqx1icbmk8s7wmbcdzsgnlh607c7kzg8l80cp02dxr5valjxp7j"))))
     (build-system haskell-build-system)
-    (arguments
-     `(#:cabal-revision
-       ("4" "0ij3asi5vwlhbgwsy6nhli9a0qb7926mg809fsgyl1rnhs9fvpx1")))
     (inputs
      `(("ghc-case-insensitive" ,ghc-case-insensitive)
        ("ghc-parser-combinators" ,ghc-parser-combinators)