diff mbox series

[bug#37402,3/4] gnu: git-annex: Build with MagicMime support.

Message ID 20190914061534.4963-3-kyle@kyleam.com
State Accepted
Headers show
Series Updates for git-annex | expand

Commit Message

Kyle Meyer Sept. 14, 2019, 6:15 a.m. UTC
git-annex has a mechanism for configuring whether a file is added to the annex
or stored in git.  Building with MagicMime support makes it possible to
condition the behavior on a file's MIME type.

* gnu/packages/haskell-apps.scm (git-annex)[inputs]: Add ghc-magic.
---
 gnu/packages/haskell-apps.scm | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 8c4048aa66..1341994e60 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -337,6 +337,7 @@  (define-public git-annex
        ("ghc-http-conduit" ,ghc-http-conduit)
        ("ghc-http-types" ,ghc-http-types)
        ("ghc-ifelse" ,ghc-ifelse)
+       ("ghc-magic" ,ghc-magic)
        ("ghc-memory" ,ghc-memory)
        ("ghc-monad-control" ,ghc-monad-control)
        ("ghc-monad-logger" ,ghc-monad-logger)