diff mbox series

[bug#37392] gnu: Add r-assertr

Message ID 20190912164457.28412-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#37392] gnu: Add r-assertr | expand

Commit Message

Wiktor Żelazny Sept. 12, 2019, 4:44 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-assertr): New variable
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ricardo Wurmus Sept. 12, 2019, 11:09 p.m. UTC | #1
Hi Wiktor,

> * gnu/packages/cran.scm (r-assertr): New variable

Thank you for your patch!

I made a couple of minor changes before pushing it to the repository’s
master branch.

> +(define-public r-assertr
> +  (package
> +    (name "r-assertr")
> +    (version "2.6")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (cran-uri "assertr" version))
> +       (sha256
> +        (base32
> +         "0g4ii6vhp0155a29ljhs64a09x0nzy5ybvwwchhk4mkcgsvnvfkj"))))
> +    (build-system r-build-system)
> +    (propagated-inputs
> +     `(("r-dplyr" ,r-dplyr)
> +       ("r-knitr" ,r-knitr)             ; needed for vignette

I moved this to native-inputs, because it is not needed at runtime.

> +    (synopsis "Assertive Programming for R Analysis Pipelines")

I changed this to use lower case.

> +    (description
> +     "Provides functionality to assert conditions that have to be met so that
> +errors in data used in analysis pipelines can fail quickly.  Similar to
> +@code{stopifnot()} but more powerful, friendly, and easier for use in
> +pipelines.")

I used full sentences here.

> +    (license (license:fsf-free "https://cran.r-project.org/web/licenses/MIT"))))

This is the Expat license, so I changed it to license:expat.

I also added punctuation to the commit message.

Thank you for your contribution and welcome to Guix!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6ef2066429..ddaffb6b6d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
+;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15365,3 +15366,29 @@  common graph algorithms.")
 removing cell free mRNA contamination (the \"soup\") from droplet based single
 cell RNA-seq experiments.")
       (license license:gpl2))))
+
+(define-public r-assertr
+  (package
+    (name "r-assertr")
+    (version "2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "assertr" version))
+       (sha256
+        (base32
+         "0g4ii6vhp0155a29ljhs64a09x0nzy5ybvwwchhk4mkcgsvnvfkj"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dplyr" ,r-dplyr)
+       ("r-knitr" ,r-knitr)             ; needed for vignette
+       ("r-mass" ,r-mass)
+       ("r-rlang" ,r-rlang)))
+    (home-page "https://github.com/ropensci/assertr")
+    (synopsis "Assertive Programming for R Analysis Pipelines")
+    (description
+     "Provides functionality to assert conditions that have to be met so that
+errors in data used in analysis pipelines can fail quickly.  Similar to
+@code{stopifnot()} but more powerful, friendly, and easier for use in
+pipelines.")
+    (license (license:fsf-free "https://cran.r-project.org/web/licenses/MIT"))))