diff mbox series

[bug#36477,v3,34/48] gnu: guile-wm: Fix cross-compilation.

Message ID 20190902153333.11190-35-m.othacehe@gmail.com
State Accepted
Headers show
Series Add --target support to guix system | expand

Commit Message

Mathieu Othacehe Sept. 2, 2019, 3:33 p.m. UTC
From: Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>

* gnu/packages/guile-wm.scm (guile-wm): Add guile and guile-xcb to native-inputs.
---
 gnu/packages/guile-wm.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Sept. 4, 2019, 12:50 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> From: Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
>
> * gnu/packages/guile-wm.scm (guile-wm): Add guile and guile-xcb to native-inputs.

LGTM!
diff mbox series

Patch

diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 6d17413901..3a6eebc91a 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -174,7 +174,9 @@  dependencies.")
                                     Type=Application~%"
                              ,name ,synopsis %output))))
                #t)))))
-      (native-inputs `(("pkg-config" ,pkg-config)
+      (native-inputs `(("guile" ,guile-2.2)
+                       ("guile-xcb" ,guile-xcb)
+                       ("pkg-config" ,pkg-config)
                        ("texinfo" ,texinfo)))
       (inputs `(("guile" ,guile-2.2)
                 ("guile-xcb" ,guile-xcb)))