diff mbox series

[bug#37275,10/19] gnu: xfce4-panel: Fix tzdata path.

Message ID 20190902140659.2506-1-guix@lprndn.info
State Accepted
Headers show
Series None | expand

Commit Message

L p R n d n Sept. 2, 2019, 2:06 p.m. UTC
* gnu/packages/xfce.scm (xfce4-panel)[inputs]: Add tzdata.
[arguments] Add Fix-tzdata-path phase.
---
 gnu/packages/xfce.scm | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Sept. 6, 2019, 10:34 p.m. UTC | #1
L  p R n  d n <guix@lprndn.info> skribis:

> * gnu/packages/xfce.scm (xfce4-panel)[inputs]: Add tzdata.
> [arguments] Add Fix-tzdata-path phase.

I made the phase name lowercase and applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 1a6de2e781..13a4cfd6ef 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -37,6 +37,7 @@ 
   #:use-module (guix build-system trivial)
   #:use-module (gnu artwork)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages pkg-config)
@@ -309,6 +310,15 @@  management D-Bus specification.")
                 "1x3flv86jh9vqah7mr5mmfx2991mc6icsqjygsc3j88lgsyz7y6m"))
               (patches (search-patches "xfce4-panel-plugins.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'Fix-tzdata-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* (string-append "plugins/clock/clock.c")
+               (("/usr/share/zoneinfo")
+                (string-append (assoc-ref inputs "tzdata") "/share/zoneinfo")))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -317,7 +327,8 @@  management D-Bus specification.")
      `(("gtk+-3" ,gtk+)                 ; required by libxfce4panel-2.0.pc
        ("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-2.0.pc
     (inputs
-     `(("exo" ,exo)
+     `(("tzdata" ,tzdata) ;; For Fix-tzdata-path phase only.
+       ("exo" ,exo)
        ("gtk+-2" ,gtk+-2)
        ("xfconf" ,xfconf)
        ("garcon" ,garcon)