diff mbox series

[bug#37273,07/19] gnu: xfconf: Fix tests.

Message ID 20190902140452.2403-1-guix@lprndn.info
State Accepted
Headers show
Series None | expand

Commit Message

L p R n d n Sept. 2, 2019, 2:04 p.m. UTC
* gnu/packages/xfce.scm (xfconf)[arguments]: Rename check phase to
  custom-check.
  [native-inputs]: Add dbus.
---
 gnu/packages/xfce.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Sept. 6, 2019, 10:24 p.m. UTC | #1
L  p R n  d n <guix@lprndn.info> skribis:

> * gnu/packages/xfce.scm (xfconf)[arguments]: Rename check phase to
>   custom-check.
>   [native-inputs]: Add dbus.

Good catch.  Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index eb14157780..31a1209167 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -127,7 +127,7 @@  Xfce Desktop Environment.")
      '(#:phases
        ;; Run check after install phase to test dbus activation.
        (modify-phases %standard-phases
-         (add-after 'install 'check
+         (add-after 'install 'custom-check
            (lambda _
              (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
              ;; Run test-suite under a dbus session.
@@ -142,7 +142,8 @@  Xfce Desktop Environment.")
        ("intltool" ,intltool)
        ("glib:bin" ,glib "bin") ;; for gdbus-codegen
        ("gobject-introspection" ,gobject-introspection)
-       ("vala" ,vala)))
+       ("vala" ,vala)
+       ("dbus" ,dbus)))
     (propagated-inputs
      ;; libxfconf-0.pc refers to all these.
      `(("glib" ,glib)))