diff mbox series

[bug#37270,02/20] gnu: Add xfce4-screensaver.

Message ID 20190902135254.1463-1-guix@lprndn.info
State Accepted
Headers show
Series None | expand

Commit Message

L p R n d n Sept. 2, 2019, 1:52 p.m. UTC
* gnu/packages/xfce.scm (xfce4-screensaver): New variable.
---
 gnu/packages/xfce.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

Comments

Ludovic Courtès Sept. 4, 2019, 9:38 p.m. UTC | #1
L  p R n  d n <guix@lprndn.info> skribis:

> * gnu/packages/xfce.scm (xfce4-screensaver): New variable.

I adjusted the indentation to match our conventions and committed.
Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 388732352e..df894b5c9a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1120,3 +1120,50 @@  window or a selected region. You can set the delay that elapses before the scree
 is taken and the action that will be done with the screenshot.
 A plugin for the Xfce panel is also available.")
    (license gpl2+)))
+
+(define-public xfce4-screensaver
+  (package
+   (name "xfce4-screensaver")
+   (version "0.1.8")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://archive.xfce.org/src/apps/"
+                                "xfce4-screensaver/"
+                                (version-major+minor version)
+                                "/xfce4-screensaver-"
+                                version ".tar.bz2"))
+            (sha256
+             (base32
+              "1mv0r150yb29kji2rr2462g9p574bqjax1lb6bzcqgpxlmg08mj0"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+         (add-after 'unpack 'fix-dbus-1-path
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (dbus-dir (string-append out "/share/dbus-1/services")))
+               (substitute* "configure"
+                            (("DBUS_SESSION_SERVICE_DIR=.*")
+                             (string-append "DBUS_SESSION_SERVICE_DIR="
+                                            dbus-dir)))))))))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)
+      ("intltool" ,intltool)
+      ("glib" ,glib)                    ; glib-compile-schemas
+      ("glib:bin" ,glib "bin")))        ; glib-compile-schemas
+   (inputs
+    `(("dbus-glib" ,dbus-glib)
+      ("libux-pam" ,linux-pam)
+      ("elogind" ,elogind)
+      ("garcon" ,garcon)
+      ("libxklavier" ,libxklavier)
+      ("libwnxk" ,libwnck)
+      ("libxscrnsaver" ,libxscrnsaver)
+      ("xfconf" ,xfconf)))
+   (home-page "https://docs.xfce.org/apps/screensaver/start")
+   (synopsis "Screensaver for the Xfce desktop")
+   (description
+    "Xfce Screensaver is a screen saver and locker that aims to have simple,
+ sane, secure defaults and be well integrated with the Xfce desktop. ")
+   (license gpl2+)))