diff mbox series

[bug#37251] gnu: txr: Update to 224.

Message ID 20190901084819.22054-1-glv@posteo.net
State Accepted
Headers show
Series [bug#37251] gnu: txr: Update to 224. | expand

Commit Message

Guillaume Le Vaillant Sept. 1, 2019, 8:48 a.m. UTC
* gnu/packages/lisp.scm (txr): Update to 224.
  [source]: Use git-fetch instead of fetching a cgit snapshot.
---
 gnu/packages/lisp.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès Sept. 1, 2019, 8:24 p.m. UTC | #1
Hi,

Guillaume Le Vaillant <glv@posteo.net> skribis:

> * gnu/packages/lisp.scm (txr): Update to 224.
>   [source]: Use git-fetch instead of fetching a cgit snapshot.

Applied!  It’s a good idea to change to ‘git-fetch’, indeed.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 34edea41de..ab1c84262e 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5337,17 +5337,18 @@  port within a range.")
 (define-public txr
   (package
     (name "txr")
-    (version "223")
+    (version "224")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://www.kylheku.com/cgit/txr/snapshot/txr-"
-                           version
-                           ".tar.bz2"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "http://www.kylheku.com/git/txr/")
+             (commit (string-append "txr-" version))))
+       (file-name (git-file-name name version))
        (patches (search-patches "txr-shell.patch"))
        (sha256
         (base32
-         "0109q8idqggba3kx58dpm5ccfpdrki68npkcxm18p5ga24611fcv"))))
+         "1036k71f6mffy9rjwzmhr5nnp1n0wzb0rqvilpzvb8jc5yxv0810"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("cc=gcc")