diff mbox series

[bug#37227,2/4] gnu: cabal-doctest: Move to haskell-check.scm.

Message ID 20190830042734.12382-2-samplet@ngyro.com
State Accepted
Headers show
Series None | expand

Commit Message

Timothy Sample Aug. 30, 2019, 4:27 a.m. UTC
From: Robert Vollmert <rob@vllmrt.net>

* gnu/packages/haskell.scm (cabal-doctest): Move variable from here...
* gnu/packages/haskell-check.scm: ...to here.

Co-authored-by: Timothy Sample <samplet@ngyro.com>
---
 gnu/packages/haskell-check.scm | 25 +++++++++++++++++++++++++
 gnu/packages/haskell.scm       | 25 -------------------------
 2 files changed, 25 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 589eee74d9..1a32382281 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -837,3 +837,28 @@  of generated values by construction.
 To get started quickly, see the examples:
 @uref{https://github.com/hedgehogqa/haskell-hedgehog/tree/master/hedgehog-example}")
     (license license:bsd-3)))
+
+(define-public cabal-doctest
+  (package
+    (name "cabal-doctest")
+    (version "1.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "cabal-doctest/cabal-doctest-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0bgd4jdmzxq5y465r4sf4jv2ix73yvblnr4c9wyazazafddamjny"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision
+       ("1" "1bk85avgc93yvcggwbk01fy8nvg6753wgmaanhkry0hz55h7mpld")))
+    (home-page "https://github.com/phadej/cabal-doctest")
+    (synopsis "Setup.hs helper for running doctests")
+    (description
+     "To properly work, the @code{doctest} package needs plenty of
+configuration.  This library provides the common bits for writing custom
+@file{Setup.hs} files.")
+    (license license:bsd-3)))
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 06d3d8afd7..cffa7e8ed7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2061,31 +2061,6 @@  API is often available directly via the standard @code{libc} C library) on
 Unix systems.")
     (license license:gpl3)))
 
-(define-public cabal-doctest
-  (package
-    (name "cabal-doctest")
-    (version "1.0.6")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://hackage.haskell.org/package/"
-                           "cabal-doctest/cabal-doctest-"
-                           version ".tar.gz"))
-       (sha256
-        (base32
-         "0bgd4jdmzxq5y465r4sf4jv2ix73yvblnr4c9wyazazafddamjny"))))
-    (build-system haskell-build-system)
-    (arguments
-     `(#:cabal-revision
-       ("1" "1bk85avgc93yvcggwbk01fy8nvg6753wgmaanhkry0hz55h7mpld")))
-    (home-page "https://github.com/phadej/cabal-doctest")
-    (synopsis "Setup.hs helper for running doctests")
-    (description
-     "To properly work, the @code{doctest} package needs plenty of
-configuration.  This library provides the common bits for writing custom
-@file{Setup.hs} files.")
-    (license license:bsd-3)))
-
 (define-public ghc-parsec-numbers
   (package
     (name "ghc-parsec-numbers")