diff mbox series

[bug#37180] gnu: gcl: Enable tests.

Message ID 20190825154401.4321-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#37180] gnu: gcl: Enable tests. | expand

Commit Message

Kei Kebreau Aug. 25, 2019, 3:44 p.m. UTC
* gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
  #:test-target to "ansi-tests/test_results".
---
 gnu/packages/lisp.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Kei Kebreau Sept. 2, 2019, 6:16 p.m. UTC | #1
Kei Kebreau <kkebreau@posteo.net> writes:

> * gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
>   #:test-target to "ansi-tests/test_results".
> ---
>  gnu/packages/lisp.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
> index d32f4b19bd..2c08e06a55 100644
> --- a/gnu/packages/lisp.scm
> +++ b/gnu/packages/lisp.scm
> @@ -113,7 +113,7 @@
>        (build-system gnu-build-system)
>        (arguments
>         `(#:parallel-build? #f  ; The build system seems not to be thread safe.
> -         #:tests? #f  ; There does not seem to be make check or anything similar.
> +         #:test-target "ansi-tests/test_results"
>           #:configure-flags '("--enable-ansi") ; required for use by the maxima package
>           #:make-flags (list
>                         (string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")

Pushed to master. The patch doesn't appear to negatively affect the
i686-linux, x86_64-linux and armhf-linux architectures.
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d32f4b19bd..2c08e06a55 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -113,7 +113,7 @@ 
       (build-system gnu-build-system)
       (arguments
        `(#:parallel-build? #f  ; The build system seems not to be thread safe.
-         #:tests? #f  ; There does not seem to be make check or anything similar.
+         #:test-target "ansi-tests/test_results"
          #:configure-flags '("--enable-ansi") ; required for use by the maxima package
          #:make-flags (list
                        (string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")