diff mbox series

[bug#37121,39/40] gnu: xfconf: Fix tests.

Message ID 20190820215043.32077-39-guix@lprndn.info
State Accepted
Headers show
Series [bug#37121,01/40] gnu: libxfce4util: Update to 4.14.0. | expand

Commit Message

L p R n d n Aug. 20, 2019, 9:50 p.m. UTC
* gnu/packages/xfce.scm (xfconf)[arguments]: Rename check phase to
  custom-check.
  [native-inputs]: Add dbus.
---
 gnu/packages/xfce.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index dd62db1449..5352ed23c6 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -128,7 +128,7 @@  Xfce Desktop Environment.")
      '(#:phases
        ;; Run check after install phase to test dbus activation.
        (modify-phases %standard-phases
-         (add-after 'install 'check
+         (add-after 'install 'custom-check
            (lambda _
              (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
              ;; Run test-suite under a dbus session.
@@ -143,7 +143,8 @@  Xfce Desktop Environment.")
        ("intltool" ,intltool)
        ("glib:bin" ,glib "bin") ;; for gdbus-codegen
        ("gobject-introspection" ,gobject-introspection)
-       ("vala" ,vala)))
+       ("vala" ,vala)
+       ("dbus" ,dbus)))
     (propagated-inputs
      ;; libxfconf-0.pc refers to all these.
      `(("glib" ,glib)))