diff mbox series

[bug#37054] gnu: wpa-supplicant: install documentation.

Message ID 20190816163649.1429-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#37054] gnu: wpa-supplicant: install documentation. | expand

Commit Message

Timotej Lazar Aug. 16, 2019, 4:36 p.m. UTC
* gnu/packages/admin.scm (wpa-supplicant):
Install READMEs and the example config file.
---
wpa_supplicant.conf(5) does not explain all configuration options but
refers to the example config file, so install it along with READMEs.

 gnu/packages/admin.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Aug. 16, 2019, 8:47 p.m. UTC | #1
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

> * gnu/packages/admin.scm (wpa-supplicant):
> Install READMEs and the example config file.
> ---
> wpa_supplicant.conf(5) does not explain all configuration options but
> refers to the example config file, so install it along with READMEs.

I tweaked the indentation, added the above explanation as a comment, and
committed the result on your behalf.

Thank you,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bd3c14033e..0b97d96582 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1240,9 +1240,10 @@  commands and their arguments.")
       CONFIG_READLINE=y\n" port)
                (close-port port))
              #t))
-         (add-after 'install 'install-man-pages
+         (add-after 'install 'install-documentation
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
+                    (doc  (string-append out "/share/doc/wpa-supplicant"))
                     (man  (string-append out "/share/man"))
                     (man5 (string-append man "/man5"))
                     (man8 (string-append man "/man8")))
@@ -1255,6 +1256,11 @@  commands and their arguments.")
                          (find-files "doc/docbook" "\\.5"))
                (for-each (copy-man-page man8)
                          (find-files "doc/docbook" "\\.8"))
+
+               (for-each
+                (lambda (file) (install-file file doc))
+                '("README" "README-DPP" "README-HS20" "README-P2P" "README-WPS"
+                  "wpa_supplicant.conf"))
                #t))))
 
       #:make-flags (list "CC=gcc"
@@ -1303,7 +1309,7 @@  command.")
       CONFIG_CTRL_IFACE_DBUS_INTRO=y\n" port)
                  (close-port port))
                #t))
-          (add-after 'install-man-pages 'install-dbus-conf
+          (add-after 'install-documentation 'install-dbus-conf
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (dir (string-append out "/etc/dbus-1/system.d")))