diff mbox series

[bug#37033] gnu: monero: Update to 0.14.1.2.

Message ID 20190814213009.10656-1-glv@posteo.net
State Accepted
Headers show
Series [bug#37033] gnu: monero: Update to 0.14.1.2. | expand

Commit Message

Guillaume Le Vaillant Aug. 14, 2019, 9:30 p.m. UTC
* gnu/packages/finance.scm (monero): Update to 0.14.1.2.
---
 gnu/packages/finance.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Efraim Flashner Aug. 15, 2019, 8:22 a.m. UTC | #1
On Wed, Aug 14, 2019 at 11:30:09PM +0200, Guillaume Le Vaillant wrote:
> * gnu/packages/finance.scm (monero): Update to 0.14.1.2.
> ---
>  gnu/packages/finance.scm | 15 ++++++++-------
>  1 file changed, 8 insertions(+), 7 deletions(-)
> 
>                  "return ((std::string(getenv(\"HOME\"))) / "))
>               #t))
> +         (add-after 'change-log-path 'fix-file-permissions-for-tests
> +           (lambda _
> +             (for-each (lambda (f)
> +                         (chmod f #o644))
> +                       (find-files "tests/data/" "wallet_9svHk1.*"))
> +             #t))
>           ;; Only try tests that don't need access to network or system
>           (replace 'check

Does 'make-file-writable' from (guix build utils) instead of 'chmod'
work here?
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7bfe5e62ff..57c12daa9b 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -445,7 +445,7 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
   ;; the system's dynamically linked library.
   (package
     (name "monero")
-    (version "0.14.1.0")
+    (version "0.14.1.2")
     (source
      (origin
        (method git-fetch)
@@ -466,7 +466,7 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
            #t))
        (sha256
         (base32
-         "1asa197fad81jfv12qgaa7y7pdr1r1pda96m9pvivkh4v30cx0nh"))))
+         "00zl883c7lcd9z7g4y3vv7rxmr7ppzrxdblnhk32r9l3qzyw55r6"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
@@ -508,6 +508,12 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
                (("return \\(")
                 "return ((std::string(getenv(\"HOME\"))) / "))
              #t))
+         (add-after 'change-log-path 'fix-file-permissions-for-tests
+           (lambda _
+             (for-each (lambda (f)
+                         (chmod f #o644))
+                       (find-files "tests/data/" "wallet_9svHk1.*"))
+             #t))
          ;; Only try tests that don't need access to network or system
          (replace 'check
            (lambda _
@@ -522,11 +528,6 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
                        "DNSResolver.DNSSECSuccess"
                        "DNSResolver.DNSSECFailure"
                        "DNSResolver.GetTXTRecord"
-                       ;; TODO: Find why portability_wallet test fails
-                       ;; Maybe the Boost version used to create the test
-                       ;; wallet and the current Boost version are not
-                       ;; completely compatible?
-                       "Serialization.portability_wallet"
                        "is_hdd.linux_os_root")
                      ":")))
                (invoke "tests/unit_tests/unit_tests"