diff mbox series

[bug#36926] gnu: Add libhandy.

Message ID 20190805001300.24655-1-jonathan@terracrypt.net
State Accepted
Headers show
Series [bug#36926] gnu: Add libhandy. | expand

Commit Message

Jonathan Frederickson Aug. 5, 2019, 12:13 a.m. UTC
gnu/packages/gnome.scm (libhandy): New variable.
---
 gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Ricardo Wurmus Aug. 5, 2019, 12:09 p.m. UTC | #1
Hi Jonathan,

thank you for this patch!

I applied a modified version of it with commit 213315d485 after these
changes:

* added a copyright line for you
* removed the ā€œvā€ from the version field (and added it to the
  git-reference instead)
* removed unneeded inputs
* moved some inputs to the native-inputs
* enabled tests (except for one)
* edited the description a little

Thanks again for your contribution!
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f7bbac214..6a3e69b5a8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8178,3 +8178,40 @@  advanced image management tool")
      "Terminator allows you to run multiple GNOME terminals in a grid and
 +tabs, and it supports drag and drop re-ordering of terminals.")
     (license license:gpl2)))
+
+(define-public libhandy
+  (package
+    (name "libhandy")
+    (version "v0.0.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://source.puri.sm/Librem5/libhandy")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1702hbdqhfpgw0c4vj2ag08vgl83byiryrbngbq11b9azmj3jhzs"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:tests? #f
+       #:configure-flags '("-Dglade_catalog=disabled")))
+    (inputs
+     `(("gobject-introspection" ,gobject-introspection)
+       ("gtk-doc" ,gtk-doc)
+       ("glib" ,glib)
+       ("gladeui" ,libglade)
+       ("gnome-desktop" ,gnome-desktop)
+       ("gtk+" ,gtk+)
+       ("libxml2" ,libxml2)
+       ("vala" ,vala)
+       ("glade" ,glade3)))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)
+       ("gettext" ,gettext-minimal)))
+    (home-page "https://source.puri.sm/Librem5/libhandy")
+    (synopsis "Library full of GTK+ widgets for mobile phones")
+    (description "The aim of the handy library is to help with developing UI
+for mobile devices using GTK+/GNOME.")
+    (license license:lgpl2.1+)))