diff mbox series

[bug#36893,1/1] gnu: r-rdae r-tm r-nlp: Add dependencies for r-wordcloud

Message ID 20190801192215.8768-1-arne_bab@web.de
State Accepted
Headers show
Series [bug#36893,1/1] gnu: r-rdae r-tm r-nlp: Add dependencies for r-wordcloud | expand

Commit Message

Dr. Arne Babenhauserheide Aug. 1, 2019, 7:22 p.m. UTC
* gnu/packages/cran.scm (r-wordcloud): Add missing dependencies
[propagated-inputs]: add r-rdae r-tm r-nlp
* gnu/packages/cran (r-rdae): New variable.
* gnu/packages/cran (r-tm): New variable.
* gnu/packages/cran (r-nlp): New variable.
---
 gnu/packages/cran.scm | 69 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 68 insertions(+), 1 deletion(-)

--
2.22.0

Comments

Ricardo Wurmus Aug. 4, 2020, 2:12 p.m. UTC | #1
Hi Arne,

thank you for your contribution.

Of all the packages added with this patch only “r-dae” didn’t exist in
(gnu packages cran) yet.  So I extracted it from your patch and made the
following changes:

- fixed the indentation
- changed the variable name from “r-rdae” to “r-dae”
- added r-r-rsp to the native inputs for vignette building
- fixed case in synopsis
- used texinfo syntax for the enumeration in the description
- removed the last sentence of the description

In the commit after that I updated the package to the current version.

Closing!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e307d2d57c..a00d71e801 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6447,6 +6447,50 @@  these limits on the basis of the mathematical properties of the distribution of
 the analyzed items.")
     (license license:gpl3)))

+(define-public r-nlp
+  (package
+    (name "r-nlp")
+    (version "0.2-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "NLP" version))
+       (sha256
+        (base32
+         "0xbhkrnxcbf322jfw31xcn4y2gnk5y7ccq1bz4h3prf44h0whr7w"))))
+    (properties `((upstream-name . "NLP")))
+    (build-system r-build-system)
+    (home-page
+     "https://cran.r-project.org/web/packages/NLP")
+    (synopsis
+     "Natural Language Processing Infrastructure")
+    (description
+     "Basic classes and methods for Natural Language Processing.")
+    (license license:gpl3)))
+
+(define-public r-tm
+  (package
+    (name "r-tm")
+    (version "0.7-6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tm" version))
+       (sha256
+        (base32 "0spv43kjbpxq3rdxx8ysgrncjyc35ydiwk7gp8n4sig45iqyz59r"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-slam" ,r-slam)
+       ("r-xml2" ,r-xml2)
+       ("r-bh" ,r-bh)
+       ("r-nlp" ,r-nlp)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/tm/")
+    (synopsis "Framework for text mining applications")
+    (description
+     "A framework for text mining applications within R.")
+    (license license:gpl2)))
+
 (define-public r-slam
   (package
     (name "r-slam")
@@ -9159,7 +9203,9 @@  pairs (Selesnick 2001, 2002).")
     (build-system r-build-system)
     (propagated-inputs
      `(("r-rcolorbrewer" ,r-rcolorbrewer)
-       ("r-rcpp" ,r-rcpp)))
+       ("r-rcpp" ,r-rcpp)
+       ("r-slam" ,r-slam)
+       ("r-tm" ,r-tm)))
     (home-page "https://cran.r-project.org/web/packages/wordcloud")
     (synopsis "Word clouds")
     (description
@@ -14334,6 +14380,27 @@  engine (Salmon et al., 2011) as provided by the package @code{sitmo}.")
     ;; whole is distributed under the terms of the AGPL 3.
     (license license:agpl3)))

+(define-public r-rdae
+  (package
+  (name "r-dae")
+  (version "3.0-32")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (cran-uri "dae" version))
+      (sha256
+        (base32
+          "0syv6kjnicb0x7sxbaavxhiv9mcqvc2zzbf4wyar933q3hzrxnrd"))))
+  (build-system r-build-system)
+  (propagated-inputs
+    `(("r-ggplot2" ,r-ggplot2) ("r-plyr" ,r-plyr)))
+  (home-page "http://chris.brien.name")
+  (synopsis
+    "Functions Useful in the Design and ANOVA of Experiments")
+  (description
+    "The content falls into the following groupings: (i) Data, (ii) Factor manipulation functions, (iii) Design functions, (iv) ANOVA functions, (v) Matrix functions, (vi) Projector and canonical efficiency functions, and (vii) Miscellaneous functions.  There is a vignette describing how to use the design functions for randomizing and assessing designs available as a vignette called 'DesignNotes'.  The ANOVA functions facilitate the extraction of information when the 'Error' function has been used in the call to 'aov'.  The package 'dae' can also be installed from <http://chris.brien.name/rpackages/>.")
+  (license license:gpl2+)))
+
 (define-public r-dalex
   (package
     (name "r-dalex")