diff mbox series

[bug#36824] gnu: Add oshu.

Message ID 20190727181841.4147-1-dfrumin@cs.ru.nl
State Accepted
Headers show
Series [bug#36824] gnu: Add oshu. | expand

Commit Message

Dan Frumin July 27, 2019, 6:18 p.m. UTC
---
 gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..3bb17c5735 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,40 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public oshu
+  (package
+    (name "oshu")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fmang/oshu.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+    (build-system cmake-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("sdl2" ,sdl2)
+              ("sdl2-image" ,sdl2-image)
+              ("ffmpeg" ,ffmpeg)
+              ("cairo" ,cairo)
+              ("pango" ,pango)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; `make test' doesn't actually build the test executable
+         (add-before 'check 'zerotokei
+           (lambda _ (invoke "make" "zerotokei"))))))
+    (home-page "https://github.com/fmang/oshu/")
+    (synopsis "Clone of the Osu! rhythm game")
+    (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful videocard. Oshu! is capable
+of playing the original Osu! beatmaps (not included in this package). ")
+    (license license:gpl3)))
+
 (define-public btanks
   (package
     (name "btanks")