diff mbox series

[bug#36692,2/2] gnu: ghc@8.6.5: Skip failing tests

Message ID 20190716185836.23128-2-rob@vllmrt.net
State Accepted
Headers show
Series [bug#36692,1/2] gnu: ghc@8.6.5: Duplicate build arguments from ghc-8.4 | expand

Commit Message

Robert Vollmert July 16, 2019, 6:58 p.m. UTC
These two tests require the existence of user root with id 0.

* gnu/packages/haskell.scm (ghc-8.6): Add phase 'skip-tests.
---
 gnu/packages/haskell.scm | 8 ++++++++
 1 file changed, 8 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0d53f16b2a..e672ea9232 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -636,6 +636,14 @@  interactive environment for the functional language Haskell.")
                      (assoc-ref inputs "ghc-testsuite")
                      "--strip-components=1")
              #t))
+         ;; These two tests refer to the root user, which doesn't exist.
+         (add-after 'unpack-testsuite 'skip-tests
+           (lambda _
+             (substitute* "libraries/unix/tests/all.T"
+               (("^test\\('T8108'") "# guix skipped: test('T8108'"))
+             (substitute* "libraries/unix/tests/libposix/all.T"
+               (("^test\\('posix010'") "# guix skipped: test('posix010'"))
+             #t))
          ;; This phase patches the 'ghc-pkg' command so that it sorts the list
          ;; of packages in the binary cache it generates.
          (add-before 'build 'fix-ghc-pkg-nondeterminism