diff mbox series

[bug#36249,v2] gnu: ghc-clock: Align version of bootstrap and real package

Message ID 20190716161605.22764-1-rob@vllmrt.net
State Accepted
Headers show
Series [bug#36249,v2] gnu: ghc-clock: Align version of bootstrap and real package | expand

Commit Message

Robert Vollmert July 16, 2019, 4:16 p.m. UTC
Fixes https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36084.

* gnu/packages/haskell-check.scm (ghc-tasty): Import ghc-clock-bootstrap
directly from (gnu packages haskell).
(ghc-clock-bootstrap): Move to...
* gnu/packages/haskell.scm (ghc-clock-bootstrap): Here and update to 0.7.2.
(ghc-clock): Inherit ghc-clock-bootstrap and build with tests.
---
 gnu/packages/haskell-check.scm | 26 +-------------------------
 gnu/packages/haskell.scm       | 20 +++++++++++++++-----
 2 files changed, 16 insertions(+), 30 deletions(-)

Comments

Timothy Sample July 16, 2019, 7:09 p.m. UTC | #1
Hi Robert,

Robert Vollmert <rob@vllmrt.net> writes:

> Fixes https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36084.
>
> * gnu/packages/haskell-check.scm (ghc-tasty): Import ghc-clock-bootstrap
> directly from (gnu packages haskell).
> (ghc-clock-bootstrap): Move to...
> * gnu/packages/haskell.scm (ghc-clock-bootstrap): Here and update to 0.7.2.
> (ghc-clock): Inherit ghc-clock-bootstrap and build with tests.
> ---
>  gnu/packages/haskell-check.scm | 26 +-------------------------
>  gnu/packages/haskell.scm       | 20 +++++++++++++++-----
>  2 files changed, 16 insertions(+), 30 deletions(-)
>
> [...]

I ended up turning this around, and basing “ghc-clock-bootstrap” on
“ghc-clock”.  It turns out we already have a bunch of packages that do
the same thing, so all that was needed was to follow those examples.

I committed a similar patch as 71e5d425c9b9e108ebdd06d13de45b56dddd9ef5,
with you as the co-author.  Thanks!


-- Tim
diff mbox series

Patch

diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index d275b5f525..294665478b 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -153,30 +153,6 @@  output file should be identical to the corresponding @code{golden} file, which
 contains the correct result for the test.")
     (license license:expat)))
 
-;; This package builds `clock` without tests, since the tests rely on tasty
-;; and tasty-quickcheck, which in turn require clock to build.
-(define ghc-clock-bootstrap
-  (package
-    (name "ghc-clock-bootstrap")
-    (version "0.5.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://hackage.haskell.org/package/"
-             "clock/"
-             "clock-" version ".tar.gz"))
-       (sha256
-        (base32 "1ncph7vi2q6ywwc8ysxl1ibw6i5dwfvln88ssfazk8jgpj4iyykw"))))
-    (build-system haskell-build-system)
-    (arguments `(#:tests? #f)) ;; Testing suite depends on tasty and
-                               ;; tasty-quickcheck, which need clock to build.
-    (home-page "https://hackage.haskell.org/package/clock")
-    (synopsis "High-resolution clock for Haskell")
-    (description "A package for convenient access to high-resolution clock and
-timer functions of different operating systems via a unified API.")
-    (license license:bsd-3)))
-
 (define-public ghc-tasty
   (package
     (name "ghc-tasty")
@@ -199,7 +175,7 @@  timer functions of different operating systems via a unified API.")
        ("ghc-unbounded-delays" ,ghc-unbounded-delays)
        ("ghc-async" ,ghc-async)
        ("ghc-ansi-terminal" ,ghc-ansi-terminal)
-       ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
+       ("ghc-clock-bootstrap" ,(@@ (gnu packages haskell) ghc-clock-bootstrap))
        ("ghc-wcwidth" ,ghc-wcwidth-bootstrap)))
     (home-page "http://documentup.com/feuerbach/tasty")
     (synopsis "Modern and extensible testing framework")
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7c910e56cb..65d8d75950 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4785,9 +4785,11 @@  or timeout period.  This package provides alternative functions which use the
 unbounded @code{Integer} type.")
     (license license:bsd-3)))
 
-(define-public ghc-clock
+;; This package builds `clock` without tests, since the tests rely on tasty
+;; and tasty-quickcheck, which in turn require clock to build.
+(define ghc-clock-bootstrap
   (package
-    (name "ghc-clock")
+    (name "ghc-clock-bootstrap")
     (version "0.7.2")
     (source
      (origin
@@ -4799,15 +4801,23 @@  unbounded @code{Integer} type.")
        (sha256
         (base32 "07v91s20halsqjmziqb1sqjp2sjpckl9by7y28aaklwqi2bh2rl8"))))
     (build-system haskell-build-system)
-    (inputs
-     `(("ghc-tasty" ,ghc-tasty)
-       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (arguments `(#:tests? #f)) ;; Testing suite depends on tasty and
+                               ;; tasty-quickcheck, which need clock to build.
     (home-page "https://hackage.haskell.org/package/clock")
     (synopsis "High-resolution clock for Haskell")
     (description "A package for convenient access to high-resolution clock and
 timer functions of different operating systems via a unified API.")
     (license license:bsd-3)))
 
+(define-public ghc-clock
+  (package
+    (inherit ghc-clock-bootstrap)
+    (name "ghc-clock")
+    (inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (arguments `(#:tests? #t))))
+
 (define-public ghc-charset
   (package
     (name "ghc-charset")