diff mbox series

[bug#36661] tests: Sort scheme tests alphabetically

Message ID 20190715105915.23913-1-rob@vllmrt.net
State Accepted
Headers show
Series [bug#36661] tests: Sort scheme tests alphabetically | expand

Commit Message

Robert Vollmert July 15, 2019, 10:59 a.m. UTC
* Makefile.am (SCM_TESTS): Sort.
---
 Makefile.am | 102 ++++++++++++++++++++++++++--------------------------
 1 file changed, 51 insertions(+), 51 deletions(-)

Comments

Efraim Flashner July 15, 2019, 12:01 p.m. UTC | #1
Can you make the backslashes line up also?
Robert Vollmert July 15, 2019, 1 p.m. UTC | #2
> On 15. Jul 2019, at 14:01, Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> Can you make the backslashes line up also?

They do?
Robert Vollmert July 22, 2019, 8:03 p.m. UTC | #3
Hi,

would someone be so kind as to apply this? It’s a bit of a pain
having to rebase it over test file additions.

(If you’re worried about the backslashes being non-aligned: Note
that this appears so in the patch for module names of lengths
3, 11, ….)

Robert
Efraim Flashner July 23, 2019, 6:57 a.m. UTC | #4
I forgot about this. Patch applied.
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index 6e2124a263..6151afd6a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -362,76 +362,76 @@  TEST_EXTENSIONS = .scm .sh
 if CAN_RUN_TESTS
 
 SCM_TESTS =					\
+  tests/accounts.scm				\
   tests/base16.scm				\
   tests/base32.scm				\
   tests/base64.scm				\
+  tests/bournish.scm				\
+  tests/builders.scm				\
+  tests/build-utils.scm				\
+  tests/cache.scm				\
+  tests/challenge.scm				\
   tests/channels.scm				\
+  tests/combinators.scm				\
+  tests/containers.scm				\
   tests/cpan.scm				\
   tests/cpio.scm				\
+  tests/cran.scm				\
   tests/crate.scm				\
-  tests/gem.scm					\
-  tests/pki.scm					\
-  tests/print.scm				\
-  tests/sets.scm				\
-  tests/modules.scm				\
-  tests/gnu-maintenance.scm			\
-  tests/substitute.scm				\
-  tests/builders.scm				\
+  tests/cve.scm					\
+  tests/debug-link.scm				\
   tests/derivations.scm				\
-  tests/glob.scm				\
-  tests/grafts.scm				\
-  tests/ui.scm					\
-  tests/status.scm				\
-  tests/records.scm				\
-  tests/processes.scm				\
-  tests/upstream.scm				\
-  tests/combinators.scm				\
   tests/discovery.scm				\
-  tests/utils.scm				\
-  tests/build-utils.scm				\
-  tests/packages.scm				\
-  tests/snix.scm				\
-  tests/hackage.scm				\
-  tests/cran.scm				\
   tests/elpa.scm				\
-  tests/texlive.scm				\
-  tests/store.scm				\
-  tests/monads.scm				\
+  tests/file-systems.scm			\
+  tests/gem.scm					\
   tests/gexp.scm				\
-  tests/nar.scm					\
-  tests/union.scm				\
-  tests/profiles.scm				\
-  tests/search-paths.scm			\
-  tests/syscalls.scm				\
-  tests/inferior.scm				\
+  tests/glob.scm				\
+  tests/gnu-maintenance.scm			\
+  tests/grafts.scm				\
+  tests/graph.scm				\
   tests/gremlin.scm				\
-  tests/debug-link.scm				\
-  tests/bournish.scm				\
+  tests/hackage.scm				\
+  tests/import-utils.scm			\
+  tests/inferior.scm				\
   tests/lint.scm				\
-  tests/publish.scm				\
-  tests/scripts.scm				\
-  tests/size.scm				\
-  tests/graph.scm				\
-  tests/challenge.scm				\
-  tests/cache.scm				\
-  tests/cve.scm					\
-  tests/workers.scm				\
-  tests/zlib.scm				\
   tests/lzlib.scm				\
-  tests/file-systems.scm			\
-  tests/uuid.scm				\
-  tests/system.scm				\
-  tests/accounts.scm				\
-  tests/services.scm				\
-  tests/scripts-build.scm			\
-  tests/containers.scm				\
+  tests/modules.scm				\
+  tests/monads.scm				\
+  tests/nar.scm					\
   tests/opam.scm				\
+  tests/packages.scm				\
   tests/pack.scm				\
+  tests/pki.scm					\
+  tests/print.scm				\
+  tests/processes.scm				\
+  tests/profiles.scm				\
+  tests/publish.scm				\
   tests/pypi.scm				\
-  tests/import-utils.scm			\
+  tests/records.scm				\
+  tests/scripts-build.scm			\
+  tests/scripts.scm				\
+  tests/search-paths.scm			\
+  tests/services.scm				\
+  tests/sets.scm				\
+  tests/size.scm				\
+  tests/snix.scm				\
+  tests/status.scm				\
   tests/store-database.scm			\
   tests/store-deduplication.scm			\
-  tests/store-roots.scm
+  tests/store-roots.scm				\
+  tests/store.scm				\
+  tests/substitute.scm				\
+  tests/syscalls.scm				\
+  tests/system.scm				\
+  tests/texlive.scm				\
+  tests/ui.scm					\
+  tests/union.scm				\
+  tests/upstream.scm				\
+  tests/utils.scm				\
+  tests/uuid.scm				\
+  tests/workers.scm				\
+  tests/zlib.scm
 
 SH_TESTS =					\
   tests/guix-build.sh				\