diff mbox series

[bug#36658] gnu: Add emacs-zerodark-theme.

Message ID 20190715092818.2490-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#36658] gnu: Add emacs-zerodark-theme. | expand

Commit Message

Giacomo Leidi July 15, 2019, 9:28 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ludovic Courtès July 17, 2019, 1:35 p.m. UTC | #1
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.

Thanks for this patch!  Below are a couple of suggestions.

> +(define-public emacs-zerodark-theme
> +  (package
> +  (name "emacs-zerodark-theme")
     ^
The indentation is off here (you can do M-q to fix it if you use
paredit).

> +  (version "20190528.923")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (string-append
> +             "https://melpa.org/packages/zerodark-theme-"
> +             version
> +             ".el"))

This URL is unstable: the file will be modified in place regularly.
Consequently, could you instead use the upstream Git repository URL
along with the ‘git-fetch’ method?

> +  (synopsis
> +    "A dark, medium contrast theme for Emacs")
        ^
Please remove “A”, as suggested by ‘guix lint’.

> +  (description
> +    "A dark theme inspired from One Dark and Niflheim.

Please write a full sentence (info "(guix) Synopses and Descriptions").

> +An optional mode-line format can be enabled with 'zerodark-setup-modeline-format'.")
                                                    ^
Please use @code as suggested by ‘guix lint’.

Could you send an updated patch?

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 47edbaeeb6..0376dc5069 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -49,6 +49,7 @@ 
 ;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
 ;;; Copyright © 2019 Amar Singh <nly@disroot.org>
 ;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16564,3 +16565,29 @@  directories, direct visualisation of image files, jumping directly to links by
 name (with autocompletion), a simple bookmark management system and
 connections using TLS encryption.")
     (license license:gpl3+)))
+
+(define-public emacs-zerodark-theme
+  (package
+  (name "emacs-zerodark-theme")
+  (version "20190528.923")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (string-append
+             "https://melpa.org/packages/zerodark-theme-"
+             version
+             ".el"))
+      (sha256
+        (base32
+          "0ajmkf6y7lvxr89cliq194qb8vzfgx4qj5c34b1pr5lrrxxaws0h"))))
+  (build-system emacs-build-system)
+  (propagated-inputs
+    `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+  (home-page
+    "https://github.com/NicolasPetton/zerodark-theme")
+  (synopsis
+    "A dark, medium contrast theme for Emacs")
+  (description
+    "A dark theme inspired from One Dark and Niflheim.
+An optional mode-line format can be enabled with 'zerodark-setup-modeline-format'.")
+  (license license:gpl3+)))