diff mbox series

[bug#36652,1/2] gnu: Add libnova.

Message ID 20190714180554.31307-1-efraim@flashner.co.il
State Accepted
Headers show
Series Add Xygrib. | expand

Commit Message

Efraim Flashner July 14, 2019, 6:05 p.m. UTC
* gnu/packages/astronomy.scm (libnova): New variable.
---
 gnu/packages/astronomy.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ludovic Courtès July 17, 2019, 1:12 p.m. UTC | #1
Hello!

Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/astronomy.scm (libnova): New variable.

[...]

> +    (synopsis "Celestial mechanics, astrometry and astrodynamics library")
> +    (description "Libnova is a general purpose, double precision, Celestial
> +Mechanics, Astrometry and Astrodynamics library.")
> +     (home-page "http://libnova.sourceforge.net/")
> +     (license (list license:lgpl2.0
        ^

Extra space here and on the line before.  :-)

From a quick sampling of the source file headers, it appears to be
‘lgpl2.0+’.


> +                    license:gpl2)))) ; examples/transforms.c & lntest/*.c

These files are ‘gpl2+’ AFAICS.

Otherwise LGTM, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4cf7c10352..2bce26a754 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -254,3 +254,38 @@  accurately in real time at any rate desired.")
     (arguments
      `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
        #:tests? #f))))
+
+(define-public libnova
+  (package
+    (name "libnova")
+    (version "0.16")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://git.code.sf.net/p/libnova/libnova.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0icwylwkixihzni0kgl0j8dx3qhqvym6zv2hkw2dy6v9zvysrb1b"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-git-version
+           (lambda _
+             (substitute* "./git-version-gen"
+               (("/bin/sh") (which "sh")))
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (synopsis "Celestial mechanics, astrometry and astrodynamics library")
+    (description "Libnova is a general purpose, double precision, Celestial
+Mechanics, Astrometry and Astrodynamics library.")
+     (home-page "http://libnova.sourceforge.net/")
+     (license (list license:lgpl2.0
+                    license:gpl2)))) ; examples/transforms.c & lntest/*.c
+