diff mbox series

[bug#36642,2/2] gnu: python-gst: Fix build failure.

Message ID 20190713220102.7416-2-mail@cbaines.net
State Accepted
Headers show
Series [bug#36643,1/2] gnu: python-pep8: Patch to fix test failure with Python 3.7. | expand

Commit Message

Christopher Baines July 13, 2019, 10:01 p.m. UTC
Building python-gst fails with:

  Unbound variable: python-version

Therefore, add python-build-system to #:modules so that it's imported, and
give it a prefix to avoid clashing with the gnu-build-system.

Also, simplify the code by using the site-packages function from the
python-build-system module.

* gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build
failure.
---
 gnu/packages/gstreamer.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

Comments

Christopher Baines July 13, 2019, 10:12 p.m. UTC | #1
Closing, as this is a duplicate of [1].

1: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36641
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b0f0b032b3..efb9a6f796 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -431,17 +431,14 @@  compression formats through the use of the libav library.")
                 "0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
     (build-system gnu-build-system)
     (arguments
-     ;; XXX: Factorize python-sitedir with python-build-system.
-     `(#:imported-modules (,@%gnu-build-system-modules
+     `(#:modules ((guix build gnu-build-system)
+                  ((guix build python-build-system) #:prefix python:))
+       #:imported-modules (,@%gnu-build-system-modules
                            (guix build python-build-system))
        #:configure-flags
-       (let* ((python (assoc-ref %build-inputs "python"))
-              (python-version (python-version python))
-              (python-sitedir (string-append
-                               "lib/python" python-version "/site-packages")))
-         (list (string-append
-                "--with-pygi-overrides-dir=" %output "/" python-sitedir
-                "/gi/overrides")))))
+       (list (string-append
+              "--with-pygi-overrides-dir=" %output "/"
+              (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python)))