diff mbox series

[bug#36641] gnu: python-gst: Fix build failure.

Message ID 20190713220059.7336-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#36641] gnu: python-gst: Fix build failure. | expand

Commit Message

Christopher Baines July 13, 2019, 10 p.m. UTC
Building python-gst fails with:

  Unbound variable: python-version

Therefore, add python-build-system to #:modules so that it's imported, and
give it a prefix to avoid clashing with the gnu-build-system.

Also, simplify the code by using the site-packages function from the
python-build-system module.

* gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build
failure.
---
 gnu/packages/gstreamer.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

Comments

Marius Bakke July 13, 2019, 10:52 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> Building python-gst fails with:
>
>   Unbound variable: python-version
>
> Therefore, add python-build-system to #:modules so that it's imported, and
> give it a prefix to avoid clashing with the gnu-build-system.
>
> Also, simplify the code by using the site-packages function from the
> python-build-system module.
>
> * gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build
> failure.
> ---
>  gnu/packages/gstreamer.scm | 15 ++++++---------
>  1 file changed, 6 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index b0f0b032b3..efb9a6f796 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -431,17 +431,14 @@ compression formats through the use of the libav library.")
>                  "0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
>      (build-system gnu-build-system)
>      (arguments
> -     ;; XXX: Factorize python-sitedir with python-build-system.
> -     `(#:imported-modules (,@%gnu-build-system-modules
> +     `(#:modules ((guix build gnu-build-system)
> +                  ((guix build python-build-system) #:prefix python:))
> +       #:imported-modules (,@%gnu-build-system-modules
>                             (guix build python-build-system))
>         #:configure-flags
> -       (let* ((python (assoc-ref %build-inputs "python"))
> -              (python-version (python-version python))
> -              (python-sitedir (string-append
> -                               "lib/python" python-version "/site-packages")))
> -         (list (string-append
> -                "--with-pygi-overrides-dir=" %output "/" python-sitedir
> -                "/gi/overrides")))))
> +       (list (string-append
> +              "--with-pygi-overrides-dir=" %output "/"

Nitpicking, but since we're refactoring, could you also change %output
to the less magical (assoc-ref %outputs "out")?


> +              (python:site-packages %build-inputs %outputs) "/gi/overrides"))))

Neat!  LGTM.
Christopher Baines July 14, 2019, 8:11 a.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> Building python-gst fails with:
>>
>>   Unbound variable: python-version
>>
>> Therefore, add python-build-system to #:modules so that it's imported, and
>> give it a prefix to avoid clashing with the gnu-build-system.
>>
>> Also, simplify the code by using the site-packages function from the
>> python-build-system module.
>>
>> * gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build
>> failure.
>> ---
>>  gnu/packages/gstreamer.scm | 15 ++++++---------
>>  1 file changed, 6 insertions(+), 9 deletions(-)
>>
>> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
>> index b0f0b032b3..efb9a6f796 100644
>> --- a/gnu/packages/gstreamer.scm
>> +++ b/gnu/packages/gstreamer.scm
>> @@ -431,17 +431,14 @@ compression formats through the use of the libav library.")
>>                  "0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
>>      (build-system gnu-build-system)
>>      (arguments
>> -     ;; XXX: Factorize python-sitedir with python-build-system.
>> -     `(#:imported-modules (,@%gnu-build-system-modules
>> +     `(#:modules ((guix build gnu-build-system)
>> +                  ((guix build python-build-system) #:prefix python:))
>> +       #:imported-modules (,@%gnu-build-system-modules
>>                             (guix build python-build-system))
>>         #:configure-flags
>> -       (let* ((python (assoc-ref %build-inputs "python"))
>> -              (python-version (python-version python))
>> -              (python-sitedir (string-append
>> -                               "lib/python" python-version "/site-packages")))
>> -         (list (string-append
>> -                "--with-pygi-overrides-dir=" %output "/" python-sitedir
>> -                "/gi/overrides")))))
>> +       (list (string-append
>> +              "--with-pygi-overrides-dir=" %output "/"
>
> Nitpicking, but since we're refactoring, could you also change %output
> to the less magical (assoc-ref %outputs "out")?

Actually, turns out that most of the stuff there was
redundant. python:site-packages did more than I was expecting, so I've
removed the use of %output entirely.

>> +              (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
>
> Neat!  LGTM.

Great, I've pushed this now.
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b0f0b032b3..efb9a6f796 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -431,17 +431,14 @@  compression formats through the use of the libav library.")
                 "0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
     (build-system gnu-build-system)
     (arguments
-     ;; XXX: Factorize python-sitedir with python-build-system.
-     `(#:imported-modules (,@%gnu-build-system-modules
+     `(#:modules ((guix build gnu-build-system)
+                  ((guix build python-build-system) #:prefix python:))
+       #:imported-modules (,@%gnu-build-system-modules
                            (guix build python-build-system))
        #:configure-flags
-       (let* ((python (assoc-ref %build-inputs "python"))
-              (python-version (python-version python))
-              (python-sitedir (string-append
-                               "lib/python" python-version "/site-packages")))
-         (list (string-append
-                "--with-pygi-overrides-dir=" %output "/" python-sitedir
-                "/gi/overrides")))))
+       (list (string-append
+              "--with-pygi-overrides-dir=" %output "/"
+              (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python)))