diff mbox series

[bug#36607,1/2] gnu: Add libimagequant.

Message ID 20190711203911.8139-2-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add pngquant and libimagequant required by it. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:39 p.m. UTC
* gnu/packages/image.scm (libimagequant): New variable.
---
 gnu/packages/image.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès July 13, 2019, 12:52 p.m. UTC | #1
Hi Hartmut,

Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> * gnu/packages/image.scm (libimagequant): New variable.
> +(define-public libimagequant
> +  (package
> +   (name "libimagequant")
      ^
Nitpick: fields should be one column further to the right.  (Maybe just
run ./etc/indent-code.el.)

> +   (home-page "https://pngquant.org/lib/")
> +   (synopsis "Image palette quantization library")
> +   (description "Small, portable C library for high-quality conversion of RGBA
> +images to 8-bit indexed-color (palette) images.")

Please write a full sentence (or two :-)).

> +   (license license:gpl3)))

It should be ‘gpl3+’ per ‘COPYRIGHT’.

OK to push with these changes, thanks!

Ludo’.
Hartmut Goebel July 13, 2019, 6:06 p.m. UTC | #2
Thansk for the review. Fixed and pushe as
6b61dea3365e8cbb6d5a918df5288489e27854e2
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index fabc2fb2d1..5a5174354c 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017,2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -313,6 +313,28 @@  files.  It can compress them as much as 40% losslessly.")
 Currently all documentation resides in @file{pnglite.h}.")
       (license license:zlib))))
 
+(define-public libimagequant
+  (package
+   (name "libimagequant")
+   (version "2.12.3")
+   (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/ImageOptim/libimagequant.git")
+            (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "0qsfq1kv1m5jzn9v9iz0bac66k4clcis1c9877qabnwzwmwma5v0"))))
+   (build-system gnu-build-system)
+   (arguments
+    '(#:tests? #f)) ; no check target
+   (home-page "https://pngquant.org/lib/")
+   (synopsis "Image palette quantization library")
+   (description "Small, portable C library for high-quality conversion of RGBA
+images to 8-bit indexed-color (palette) images.")
+   (license license:gpl3)))
+
 (define-public libjpeg
   (package
    (name "libjpeg")