diff mbox series

[bug#36606] gnu: Add emacs-elpher.

Message ID 20190711203500.23812-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#36606] gnu: Add emacs-elpher. | expand

Commit Message

Arun Isaac July 11, 2019, 8:34 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-elpher): New variable.
---
 gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ludovic Courtès July 13, 2019, 12:49 p.m. UTC | #1
Hello,

Arun Isaac <arunisaac@systemreboot.net> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-elpher): New variable.

Nice package.  :-)  LGTM!

Ludo’.
Arun Isaac July 14, 2019, 2:58 p.m. UTC | #2
Thanks for the review! Pushed to master!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d9f271cc8..78bd630ecf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16481,3 +16481,37 @@  it forcibly
 @item Dedicated window for debugging program.
 @end enumerate")
       (license license:gpl3+))))
+
+(define-public emacs-elpher
+  (package
+    (name "emacs-elpher")
+    (version "1.4.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tgvaughan/elpher")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "07xansmhn4l0b9ghzf56vyx8cqg0q01aq3pz5ikx2i19v5f0rc66"))))
+    (build-system emacs-build-system)
+    (native-inputs
+     `(("texinfo" ,texinfo)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'build-doc
+           (lambda _
+             (invoke "makeinfo" "elpher.texi"))))))
+    (home-page "https://github.com/tgvaughan/elpher")
+    (synopsis "Gopher client for Emacs")
+    (description "Elpher is a full-featured gopher client for Emacs.  Its
+features include intuitive keyboard and mouse-driven browsing, out-of-the-box
+compatibility with evil-mode, clickable web and gopher links in plain text,
+caching of visited sites, pleasant and configurable visualization of Gopher
+directories, direct visualisation of image files, jumping directly to links by
+name (with autocompletion), a simple bookmark management system and
+connections using TLS encryption.")
+    (license license:gpl3+)))