diff mbox series

[bug#36605] gnu: Add anonip.

Message ID 20190711202644.32014-3-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#36605] gnu: Add anonip. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:26 p.m. UTC
* gnu/packages/web.scm (anonip): New variable.
---
 gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 124cc93e68..386564206e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6498,3 +6499,34 @@  update an existing mirrored site, and resume interrupted downloads.
 
 HTTrack is fully configurable, and has an integrated help system.")
     (license license:gpl3+)))
+
+(define-public anonip
+  (package
+    (name "anonip")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "anonip" version))
+              (sha256
+               (base32
+                "0ckn9nnfhpdnz8b92q8pkysdqj6pdh71ckfqvfj0z01cq0hzbhd2"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-3" ,python-3)))
+    (home-page
+     "https://github.com/DigitaleGesellschaft/Anonip")
+    (synopsis
+     "Anonymize IP-addresses in log-files")
+    (description
+     "Anonip masks the last bits of IPv4 and IPv6 addresses in log-files.
+That way most of the relevant information is preserved, while the IP-address
+does not match a particular individuum anymore.
+
+Depending on your webserver software, the log entries may directly get piped
+to Anonip or read via a FIFO (named pipe).  Thus the unmasked IP addresses
+will never be written to any file.
+
+It's also possible to rewrite existing log files.
+
+Anonip can also be uses as a Python module in your own Python application.")
+    (license license:bsd-3)))