diff mbox series

[bug#36605,08/12] gnu: Add java-commons-daemon.

Message ID 20190711202644.32014-22-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#36605,v4] daemon: Set ownership of kept build directories to the calling user. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:26 p.m. UTC
* gnu/packages/java.scm (java-commons-daemon): New variable.
---
 gnu/packages/java.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a5d3a25..e200296 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1396,3 +1396,35 @@  phonetic encoding utilities.
 
 This is a part of the Apache Commons Project.")
     (license license:asl2.0)))
+
+(define-public java-commons-daemon ; build, todo: verify results
+  (package    (name "java-commons-daemon")
+    (version "1.0.15")
+    (source (origin
+      (method url-fetch)
+      (uri (apache-commons-url "daemon" version))
+      (sha256
+       (base32 "0ci46kq8jpz084ccwq0mmkahcgsmh20ziclp2jf5i0djqv95gvhi"))))
+    (build-system ant-build-system)
+    (outputs '("out" "doc"))
+    (arguments
+     `(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'build 'build-javadoc ant-build-javadoc)
+         (replace 'install (install-jars "dist"))
+         (add-after 'install 'install-doc (install-javadoc "dist/docs/api")))))
+    (native-inputs
+     `(("java-junit" ,java-junit)))
+    (home-page "http://commons.apache.org/daemon/")
+    (synopsis "Library to launch Java applications as daemons")
+    (description "The Daemon package from Apache Commons can be used to
+implement Java applications which can be launched as daemons.  For example the
+program will be notified about a shutdown so that it can perform cleanup tasks
+before its process of execution is destroyed by the operation system.
+
+This package contains the java library.  You will also need the actual binary
+for your architecture which is provided by the jsvc package.
+
+This is a part of the Apache Commons Project.")
+    (license license:asl2.0)))