diff mbox series

[bug#36605,05/12] gnu: Add java-plexus-interpolation.

Message ID 20190711202644.32014-19-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#36605,v4] daemon: Set ownership of kept build directories to the calling user. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:26 p.m. UTC
* gnu/packages/java.scm (java-plexus-interplation): New variable.
---
 gnu/packages/java.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0dfd9fa..3687c7e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1288,3 +1288,31 @@  sharing common test data, and test runners for running tests.")
     (description "Various Java utility classes to ease working with strings,
 files, command lines, XML and more.")
     (license license:asl2.0)))
+
+(define-public java-plexus-interpolation
+  (package
+    (name "java-plexus-interpolation")
+    (version "1.23")
+    (source (origin
+      (method url-fetch)
+      (uri (codehaus-plexus-url "interpolation" version))
+      (sha256 (base32 "1w79ljwk42ymrgy8kqxq4l82pgdj6287gabpfnpkyzbrnclsnfrp"))))
+    (build-system ant-build-system)
+    ; todo: javadoc
+    (arguments
+     `(#:tests? #f ; todo: tests
+       #:jar-name (string-append "plexus-interpolation-" ,version ".jar")
+       #:src-dir "src/main"))
+    (native-inputs
+     `(("java-junit" ,java-junit)))
+    (home-page "http://codehaus-plexus.github.io/plexus-interpolation/")
+    (synopsis "Java components for interpolating ${} strings and the like")
+    (description "Plexus interpolator is the outgrowth of multiple iterations
+of development focused on providing a more modular, flexible interpolation
+framework for the expression language style commonly seen in Maven, Plexus,
+and other related projects.
+
+It has its foundation in the org.codehaus.plexus.utils.interpolation package
+within plexus-utils, but has been separated in order to allow these two
+libraries to vary independently of one another.")
+    (license license:asl2.0)))