diff mbox series

[bug#36605,04/12] gnu: Add java-plexus-utils.

Message ID 20190711202644.32014-18-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#36605,v4] daemon: Set ownership of kept build directories to the calling user. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:26 p.m. UTC
* gnu/packages/java.scm (codehaus-plexus-url): New function.
  (java-plexus-utils): New variable.
---
 gnu/packages/java.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e8d09dd..0dfd9fa 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1256,3 +1256,35 @@  testing frameworks, mocking libraries and UI validation rules.")
 JUnit provides assertions for testing expected results, test fixtures for
 sharing common test data, and test runners for running tests.")
     (license license:epl1.0)))
+
+;
+; codehaus plexus
+;
+
+(define* (codehaus-plexus-url projname version)
+  (let ((projname (string-append "plexus-" projname)))
+    (string-append "https://github.com/codehaus-plexus/" projname
+                   "/archive/" projname "-" version ".tar.gz")))
+
+(define-public java-plexus-utils
+  (package
+    (name "java-plexus-utils")
+    (version "3.0.24")
+    (source (origin
+      (method url-fetch)
+      (uri (codehaus-plexus-url "utils" version))
+      (sha256
+       (base32 "1mlwpc6fms24slygv5yvi6fi9hcha2fh0v73p5znpi78bg36i2js"))))
+    (build-system ant-build-system)
+    ; todo: javadoc
+    (arguments
+     `(#:tests? #f ; todo: tests
+       #:jar-name (string-append "plexus-utils-" ,version ".jar")
+       #:src-dir "src/main"))
+    (native-inputs
+     `(("java-junit" ,java-junit)))
+    (home-page "http://codehaus-plexus.github.io/plexus-utils/")
+    (synopsis "Common utilities for the Plexus framework")
+    (description "Various Java utility classes to ease working with strings,
+files, command lines, XML and more.")
+    (license license:asl2.0)))