diff mbox series

[bug#36605,3/3] gnu: Remove now useless #:tests? #f from java-packages.

Message ID 20190711202644.32014-13-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#36605,v4] daemon: Set ownership of kept build directories to the calling user. | expand

Commit Message

Hartmut Goebel July 11, 2019, 8:26 p.m. UTC
With the last commit, when #:jar-name is given, a dummy test-target
always exists.

* gnu/packages/java.scm (java-junit, java-swt, java-xz): Remove
  build-argument `#:tests?'.
---
 gnu/packages/java.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7387235..e8d09dd 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -84,7 +84,6 @@ 
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "swt.jar"
-       #:tests? #f ; no "check" target
        #:phases
        (modify-phases %standard-phases
          (replace 'unpack
@@ -1054,8 +1053,7 @@  build process and its dependencies, whereas Make uses Makefile format.")
        "0x6vn9dp9kxk83x2fp3394n95dk8fx9yg8jns9371iqsn0vy8ih1"))))
    (build-system ant-build-system)
    (arguments
-    `(#:tests? #f ; There are no tests to run.
-      #:jar-name ,(string-append "xz-" version  ".jar")
+    `(#:jar-name ,(string-append "xz-" version  ".jar")
       #:phases
       (modify-phases %standard-phases
         ;; The unpack phase enters the "maven" directory by accident.
@@ -1248,8 +1246,7 @@  testing frameworks, mocking libraries and UI validation rules.")
                   #t))))
     (build-system ant-build-system)
     (arguments
-     `(#:tests? #f ; no tests
-       #:jar-name "junit.jar"))
+     `(#:jar-name "junit.jar"))
     (inputs
      `(("java-hamcrest-core" ,java-hamcrest-core)))
     (home-page "http://junit.org/")