diff mbox series

[bug#36541] gnu: Add s-tui.

Message ID 20190707175503.11386-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#36541] gnu: Add s-tui. | expand

Commit Message

Christopher Baines July 7, 2019, 5:55 p.m. UTC
* gnu/packages/admin.scm (s-tui): New variable.
---
 gnu/packages/admin.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès July 12, 2019, 2:31 p.m. UTC | #1
Hello,

Christopher Baines <mail@cbaines.net> skribis:

> * gnu/packages/admin.scm (s-tui): New variable.

LGTM!  :-)

Ludo’.
Christopher Baines July 13, 2019, 10:20 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/admin.scm (s-tui): New variable.
>
> LGTM!  :-)

Great, I've pushed this as bee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23
now. Thanks for taking a look :)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 411be40f5b..98795966f1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1453,6 +1453,28 @@  tables.  This package contains only the user-space tools needed for ACPI table
 development, not the kernel implementation of ACPI.")
     (license license:gpl2)))            ; dual GPLv2/ACPICA Licence
 
+(define-public s-tui
+  (package
+    (name "s-tui")
+    (version "0.8.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "s-tui" version))
+       (sha256
+        (base32
+         "00lsh2v4i8rwfyjyxx5lijd6rnk9smcfffhzg5sv94ijpcnh216m"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-psutil" ,python-psutil)
+       ("python-urwid" ,python-urwid)))
+    (home-page "https://github.com/amanusk/s-tui")
+    (synopsis "Interactive terminal stress test and monitoring tool")
+    (description
+     "The Stress Terminal UI displays graphs of the CPU frequency,
+utilization, temperature and power.")
+    (license license:gpl2+)))
+
 (define-public stress
   (package
     (name "stress")