diff mbox series

[bug#36446] Add grisbi

Message ID 20190707154044.bstjb7fwu4nez2hu@melmoth
State Accepted
Headers show
Series [bug#36446] Add grisbi | expand

Commit Message

Tanguy LE CARROUR July 7, 2019, 3:40 p.m. UTC
Thanks again for reading it. Here is the updated (and rebased) version.

---
 gnu/packages/finance.scm | 41 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Timothy Sample July 12, 2019, 4:26 p.m. UTC | #1
Hi Tanguy,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> Thanks again for reading it. Here is the updated (and rebased) version.

With the minor changes to the synopsis and description that I mentioned
before, I pushed this as 90bb244f29cacba8a098c07cd7c19a77d16f6cfb.

Thanks!

(As a note for the future, please be sure your patches apply.  I had to
fix the boundaries on one of the hunks.)


-- Tim
Tanguy LE CARROUR July 15, 2019, 6:55 a.m. UTC | #2
Hi Timothy,

Le 07/12, Timothy Sample a écrit :
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> With the minor changes to the synopsis and description that I mentioned
> before, I pushed this as 90bb244f29cacba8a098c07cd7c19a77d16f6cfb.

Thank you so much for that!

> (As a note for the future, please be sure your patches apply.  I had to
> fix the boundaries on one of the hunks.)

I'm really sorry to hear that! I'll do my best next time not to give you
extra work!

Best regards!
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 550354b650..c0a56f5180 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages boost)
@@ -47,9 +49,12 @@ 
   #:use-module (gnu packages dns)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages libedit)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
@@ -1050,3 +1055,39 @@  Its features are:
 @item get account amount.
 @end itemize")
     (license license:agpl3+)))
+
+(define-public grisbi
+  (package
+    (name "grisbi")
+    (version "1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://sourceforge/grisbi/grisbi%20stable"
+             "/" (version-major+minor version) ".x"
+             "/" version "/grisbi-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "1piiyyxjsjbw9gcqydvknzxmmfgh8kdqal12ywrxyxih2afwnvbw"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags (list "--without-ofx")))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
+    (native-inputs
+     `(("glib" ,glib "bin")             ; glib-compile-schemas
+       ("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("libgsf" ,libgsf)))
+    (synopsis "Personnal accounting application")
+    (description "Grisbi is an application written by French developers,
+so it perfectly respects French accounting rules.  Grisbi can manage
+multiple accounts, currencies and users.  It manages third party,
+expenditure and receipt categories, budgetary lines, financial years,
+budget estimates, bankcard management and other information that make Grisbi
+adapted for associations.")
+    (home-page "http://grisbi.org")
+    (license license:gpl2+)))