diff mbox series

[bug#36446] Add grisbi

Message ID 20190630115445.e4td6p7upcsrk6hg@melmoth
State Accepted
Headers show
Series [bug#36446] Add grisbi | expand

Commit Message

Tanguy LE CARROUR June 30, 2019, 11:54 a.m. UTC
---
 gnu/packages/finance.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Efraim Flashner July 2, 2019, 9:33 a.m. UTC | #1
I haven't checked the package, but one thing stood out to me:

On Sun, Jun 30, 2019 at 01:54:45PM +0200, Tanguy Le Carrour wrote:
> ---
> +    (version "1.2.2")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append
> +               "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"

1.2.x could instead be:
(verion-major+minor version) ".x"

> +               "/" version "/grisbi-" version ".tar.bz2"))
> 
>
Tanguy LE CARROUR July 3, 2019, 7 a.m. UTC | #2
Le 07/02, Efraim Flashner a écrit :
> I haven't checked the package, but one thing stood out to me:
> 
> On Sun, Jun 30, 2019 at 01:54:45PM +0200, Tanguy Le Carrour wrote:
> > ---
> > +    (version "1.2.2")
> > +    (source
> > +      (origin
> > +        (method url-fetch)
> > +        (uri (string-append
> > +               "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"
> 
> 1.2.x could instead be:
> (verion-major+minor version) ".x"

Thanks for the tip! I didn't know about this one, but it makes perfect
sense!
Am I supposed to update my patch and re-submit it? (sorry, newbie! ^_^')
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e1a1e8ab6f..d3e12c2618 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +36,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages boost)
@@ -45,9 +47,12 @@ 
   #:use-module (gnu packages dns)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages libedit)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
@@ -1028,3 +1033,38 @@  Its features are:
 @item get account amount.
 @end itemize")
     (license license:agpl3+)))
+
+(define-public grisbi
+  (package
+    (name "grisbi")
+    (version "1.2.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://sourceforge/grisbi/grisbi%20stable/1.2.x"
+               "/" version "/grisbi-" version ".tar.bz2"))
+        (sha256
+          (base32
+            "1piiyyxjsjbw9gcqydvknzxmmfgh8kdqal12ywrxyxih2afwnvbw"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags (list "--without-ofx")))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
+    (native-inputs
+      `(("glib" ,glib "bin")             ; glib-compile-schemas
+        ("pkg-config" ,pkg-config)
+        ("intltool" ,intltool)))
+    (inputs
+      `(("gtk+" ,gtk+)
+        ("libgsf" ,libgsf)))
+    (synopsis "Personnal accounting application")
+    (description "Grisbi is an application written by French developers,
+so it perfectly respects French accounting rules.  Grisbi can manage
+multiple accounts, currencies and users.  It manages third party,
+expenditure and receipt categories, budgetary lines, financial years,
+budget estimates, bankcard management and other information that make Grisbi
+adapted for associations.")
+    (home-page "http://grisbi.org")
+    (license license:gpl2+)))