diff mbox series

[bug#36387] gnu: mesa: Fix detection of wayland-scanner pkg-config file.

Message ID 20190626015345.19432-2-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#36387] gnu: mesa: Fix detection of wayland-scanner pkg-config file. | expand

Commit Message

Kei Kebreau June 26, 2019, 1:53 a.m. UTC
* gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
---
 gnu/packages/gl.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Maxim Cournoyer Nov. 14, 2021, 1:22 a.m. UTC | #1
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
> ---
>  gnu/packages/gl.scm | 9 +++++++++
>  1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 96e7fc7165..78f7401f20 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
>                         (("'u_format_test',") ""))
>                       #t)))
>                 '())
> +         (add-after
> +           'unpack 'patch-meson-build
> +           (lambda _
> +             ;; Without this, meson fails with the following error:
> +             ;; Dependency "wayland-scanner" not found, tried pkgconfig.
> +             (substitute* "meson.build"
> +               (("dependency\\('wayland-scanner', native: true\\)")
> +                "dependency('wayland-scanner')"))
> +             #t))
>           (add-before
>             'configure 'fix-dlopen-libnames
>             (lambda* (#:key inputs outputs #:allow-other-keys)

Was this fixing a build failure of mesa itself?  Or does it manifest
when building other packages depending on mesa?

Given the patch is 2 years old, I'm guessing it went stale?

Thanks,

Maxim
Kei Kebreau Dec. 27, 2021, 1:46 p.m. UTC | #2
It did in fact go stale. I vaguely remember having some trouble building 
mesa locally, but this no longer seems to be the case.

On 11/13/21 8:22 PM, Maxim Cournoyer wrote:
> Hello,
>
> Kei Kebreau<kkebreau@posteo.net>  writes:
>
>> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
>> ---
>>   gnu/packages/gl.scm | 9 +++++++++
>>   1 file changed, 9 insertions(+)
>>
>> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
>> index 96e7fc7165..78f7401f20 100644
>> --- a/gnu/packages/gl.scm
>> +++ b/gnu/packages/gl.scm
>> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
>>                          (("'u_format_test',") ""))
>>                        #t)))
>>                  '())
>> +         (add-after
>> +           'unpack 'patch-meson-build
>> +           (lambda _
>> +             ;; Without this, meson fails with the following error:
>> +             ;; Dependency "wayland-scanner" not found, tried pkgconfig.
>> +             (substitute* "meson.build"
>> +               (("dependency\\('wayland-scanner', native: true\\)")
>> +                "dependency('wayland-scanner')"))
>> +             #t))
>>            (add-before
>>              'configure 'fix-dlopen-libnames
>>              (lambda* (#:key inputs outputs #:allow-other-keys)
> Was this fixing a build failure of mesa itself?  Or does it manifest
> when building other packages depending on mesa?
>
> Given the patch is 2 years old, I'm guessing it went stale?
>
> Thanks,
>
> Maxim
Maxim Cournoyer Dec. 28, 2021, 2:34 a.m. UTC | #3
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

> It did in fact go stale. I vaguely remember having some trouble
> building mesa locally, but this no longer seems to be the case.

Alright, thank you for the heads up.  Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96e7fc7165..78f7401f20 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -337,6 +337,15 @@  also known as DXTn or DXTC) for Mesa.")
                        (("'u_format_test',") ""))
                      #t)))
                '())
+         (add-after
+           'unpack 'patch-meson-build
+           (lambda _
+             ;; Without this, meson fails with the following error:
+             ;; Dependency "wayland-scanner" not found, tried pkgconfig.
+             (substitute* "meson.build"
+               (("dependency\\('wayland-scanner', native: true\\)")
+                "dependency('wayland-scanner')"))
+             #t))
          (add-before
            'configure 'fix-dlopen-libnames
            (lambda* (#:key inputs outputs #:allow-other-keys)