diff mbox series

[bug#36271] gnu: Add numix-theme.

Message ID 20190617235805.4300-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#36271] gnu: Add numix-theme. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Giacomo Leidi June 17, 2019, 11:58 p.m. UTC
* gnu/packages/gnome.scm (numix-theme): New variable
---
 gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 875d28caee..eeca6edd4b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6880,6 +6881,39 @@  functionality and behavior.")
     (home-page "https://extensions.gnome.org/")
     (license license:gpl3+)))
 
+(define-public numix-theme
+  (package
+    (name "numix-theme")
+    (version "2.6.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/numixproject/numix-gtk-theme.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'check))))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")             ; for glib-compile-schemas
+       ("gnome-shell" ,gnome-shell)
+       ("gtk+" ,gtk+)
+       ("xmllint" ,libxml2)
+       ("ruby-sass" ,ruby-sass)))
+    (synopsis "Numix is a modern flat theme with a combination of light
+ and dark elements")
+    (description "A modern flat theme with a combination of light and dark elements.
+ It supports GNOME, Unity, Xfce and Openbox.")
+    (home-page "https://numixproject.github.io")
+    (license license:gpl3+)))
+
 (define-public arc-theme
   (package
     (name "arc-theme")