diff mbox series

[bug#36211,2/3] gnu: Add osm-gps-map

Message ID 20190614172751.22468-3-glv@posteo.net
State Accepted
Headers show
Series Add gramps and dependencies | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Guillaume Le Vaillant June 14, 2019, 5:27 p.m. UTC
* gnu/packages/geo.scm (osm-gps-map): New variable.
---
 gnu/packages/geo.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ec5ace3519..07831c85ca 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -869,3 +869,39 @@  dropping features at lower levels.")
 OpenStreetMap project.  They can be used to convert, filter and update
 OpenStreetMap data files.")
     (license license:agpl3)))
+
+(define-public osm-gps-map
+  (package
+    (name "osm-gps-map")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/nzjrs/osm-gps-map/releases/download/"
+             version
+             "/osm-gps-map-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gnome-common" ,gnome-common)
+       ("gtk-doc" ,gtk-doc)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("glib" ,glib)
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+" ,gtk+)
+       ("libsoup" ,libsoup)))
+    (home-page "https://nzjrs.github.io/osm-gps-map/")
+    (synopsis "Gtk+ widget for displaying OpenStreetMap tiles")
+    (description
+     "A Gtk+ widget (and Python bindings) that when given GPS coordinates,
+draws a GPS track, and points of interest on a moving map display.
+Downloads map data from a number of websites, including
+@url{https://www.openstreetmap.org}.")
+    (license license:gpl2+)))