diff mbox series

[bug#36182] add freeorion

Message ID 20190613185709.1a97b9ae@gmail.com
State Accepted
Headers show
Series [bug#36182] add freeorion | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jesse Gibbons June 14, 2019, 12:57 a.m. UTC
On Thu, 13 Jun 2019 22:56:41 +0200
Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Jesse Gibbons <jgibbons2357@gmail.com> writes:
> 
> > On Wed, 12 Jun 2019 21:48:52 +0200
> > Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:  
> 
> >> If you use Emacs, there is a template to automatically fill this.  
> > I did not know this. How do I use the template?  
> 
> See "The Perfect Setup" section of the Guix manual, in particular the
> part about Yasnippet.
I will look into this later.
> 
> > I added a comment to explain why I specify the most recent commit. I
> > also added a note that it should be updated when the next stable
> > release is available (the maintainers seem to prefer announcing new
> > releases every September). I will personally update this in
> > mid-September or October if version 0.4.8.1 or 0.4.9 or 0.5 or 1.0
> > is available and no volunteer beats me to it. If you want I can also
> > request release 0.4.8.1 ASAP so we can specify a release rather
> > than a commit. I personally prefer to keep the commit and wait
> > three or four months for the release.  
> 
> Fair enough. Thank you for the explanation.
> 
> I think we also need a
> 
>   (file-name (git-file-name name version))
> 
> in the source.
Ok.
> 
> >> > +    (home-page
> >> > +     "https://www.freeorion.org/index.php/Main_Page")    
> >> 
> >> I think "https://www.freeorion.org" is enough, since it points to
> >> the page above.  
> 
> You probably overlooked that remark.
No, i just forgot. It's fixed now, but 'guix lint' does not like it.
> 
> > The link says that 4X refers to a genre of strategy game centered
> > around conquest. I think the current context is a sufficient
> > explanation, but I did expand the description. I think it is best to
> > keep the 4X in the description in case someone tries a search for
> > that genre.  
> 
> OK.
> 
> > I added comments to explain these licenses.  
> 
> According to
> <https://www.freeorion.org/index.php/FreeOrionWiki:Copyrights>, the
> source code is released under gpl2, artwork, music and sounds, and
> in-game text are released under cc-by-sa3.0, and the game content
> scripts are released under both gpl2 and cc-by-sa3.0.
I got my information from github. I'll update.
> 
> So, the comments should include the description above, for
> completeness.
> 
> > Updated patch is attached. Is there anything else you want me to
> > fix?  
> 
> Great. I'm adding some small remarks, but overall the patch LGTM.
> 
> > +;;;Most recent stable release uses boost_signals (v1)
> > +;;;which was later replaced with boost-signals2 and
> > +;;;no longer exists. This commit builds and runs.
> > +;;;TODO: Update this when the next stable release when
> > +;;;it is available.  
> 
> In Scheme, such comments use ";; " as a prefix.
Fixed.
> 
> > +             (commit "470d0711537804df3c2ca25532f674ab4bec58af")))
> > +       (sha256
> > +        (base32
> > +         "1wsw632l1cj17px6i88nqjzs0dngp5rsr67n6qkkjlfjfxi69j0f"))))
> > +    (arguments
> > +     '(#:tests? #f))                    ;no test
> > +    (build-system cmake-build-system)
> > +    (inputs `(("boost" ,boost)
> > +              ("boost_signals" ,boost-signals2)
> > +              ("freetype2" ,freetype)
> > +              ("python2" ,python-2.7)
> > +              ("openal" ,openal)
> > +              ("libogg" ,libogg)
> > +              ("libvorbis" ,libvorbis)
> > +              ("zlib" ,zlib)
> > +              ("libpng" ,libpng)
> > +              ("sdl2" ,sdl2)
> > +              ("glu" ,glu)
> > +              ("glew" ,glew)))  
> 
> Could you re-order inputs alphabetically?
Done.
> 
> > +    (home-page
> > +     "https://www.freeorion.org/index.php/Main_Page")  
> 
> See above.
> 
> Also, don't forget to add yourself to the Hall of Fame at the top of
> the "games.scm" file.
I did that when I added gnurobots.
> 
> Can you send an updated patch? Hopefully I should be able to apply it
> then.
Attached.
> 
> Thank you!

Comments

Nicolas Goaziou June 16, 2019, 7:46 p.m. UTC | #1
Hello,

Jesse Gibbons <jgibbons2357@gmail.com> writes:

> No, i just forgot. It's fixed now, but 'guix lint' does not like it.

Oh, you're right. I reverted my suggestion.

> I got my information from github. I'll update.

I also added lgpl2.1 since there is a bundled library (GiGi) with that
license.

I also unbundled DejaVu and Roboto fonts.

>> Can you send an updated patch? Hopefully I should be able to apply it
>> then.

> Attached.

I removed "free, open-source " from the description of the package and
applied the changes above. Thank you!

Regards,
diff mbox series

Patch

From d6230c5286b95e9c8f2acc3662bddb1a20346251 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Thu, 13 Jun 2019 18:48:43 -0600
Subject: [PATCH] add freeorion      * gnu/packages/games.scm (freeorion): New
 variable.

---
 gnu/packages/games.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 86bdf99a32..4d6b06d55c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7455,3 +7455,52 @@  steam locomotive across many levels and collect all the coaches to
 win.")
     ;; The project is dual-licensed GPL2+ and GPL3+.
     (license (list license:gpl2+ license:gpl3+))))
+
+(define-public freeorion
+  (package
+    (name "freeorion")
+    (version "0.4.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/freeorion/freeorion.git")
+             ;;Most recent stable release uses boost_signals (v1) which was later
+             ;;replaced with boost-signals2 and no longer exists. This commit builds
+             ;;and runs.
+             ;;TODO: Update this when the next stable release when it is available.
+             (commit "470d0711537804df3c2ca25532f674ab4bec58af")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1wsw632l1cj17px6i88nqjzs0dngp5rsr67n6qkkjlfjfxi69j0f"))))
+    (arguments
+     '(#:tests? #f))                    ;no test
+    (build-system cmake-build-system)
+    (inputs
+     `(("boost" ,boost)
+       ("boost_signals" ,boost-signals2)
+       ("freetype2" ,freetype)
+       ("glew" ,glew)
+       ("glu" ,glu)
+       ("libogg" ,libogg)
+       ("libpng" ,libpng)
+       ("libvorbis" ,libvorbis)
+       ("openal" ,openal)
+       ("python2" ,python-2.7)
+       ("sdl2" ,sdl2)
+       ("zlib" ,zlib)))
+    (home-page
+     "https://www.freeorion.org/")
+    (synopsis
+     "Turn-based space empire and galactic conquest computer game")
+    (description
+     "FreeOrion is a free, open source, turn-based space empire and galactic
+conquest (4X) computer game being designed and built by the FreeOrion project.
+Control an empire with the goal of exploring the galaxy, expanding your
+territory, exploiting the resources, and exterminating rival alien empires.
+FreeOrion is inspired by the tradition of the Master of Orion games, but is not
+a clone or remake of that series or any other game.")
+    (license (list
+              license:gpl2           ;game code, game content, scripts
+              license:cc-by-sa3.0))));artwork, music, sound, game content, scripts
-- 
2.22.0