diff mbox series

[bug#36194,08/10] gnu: Add python-agate-dbf.

Message ID 20190613150627.1882-8-pierre.langlois@gmx.com
State Accepted
Headers show
Series Add csvkit. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Pierre Langlois June 13, 2019, 3:06 p.m. UTC
* gnu/packages/wireservice.scm (python-agate-dbf): New variable.
---
 gnu/packages/wireservice.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.22.0
diff mbox series

Patch

diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index 575b63792b..4a8e7681ed 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -146,3 +146,25 @@  code.  Agate was previously known as journalism.")))
     (synopsis "SQL read/write support to agate")
     (description "@code{agatesql} uses a monkey patching pattern to add SQL
 support to all @code{agate.Table} instances.")))
+
+(define-public python-agate-dbf
+  (package
+    (inherit base-package)
+    (name "python-agate-dbf")
+    (version "0.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/wireservice/agate-dbf.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1y49fi6pmm7gzhajvqmfpcca2sqnwj24fqnsvzwk7r1hg2iaa2gi"))))
+    (propagated-inputs
+     `(("python-agate" ,python-agate)
+       ("python-dbfread" ,python-dbfread)))
+    (home-page "https://agate-dbf.rtfd.org")
+    (synopsis "Add read support for dbf files to agate")
+    (description "@code{agatedbf} uses a monkey patching pattern to add read
+for dbf files support to all @code{agate.Table} instances.")))