diff mbox series

[bug#36181] gnu: Add emacs-org-noter

Message ID 20190612132604.4880-1-bendersteed@teknik.io
State Accepted
Headers show
Series [bug#36181] gnu: Add emacs-org-noter | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Dimakakos Dimos June 12, 2019, 1:26 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ca1eb586df..e7ae46cecc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15863,3 +15863,31 @@  corresponding Evil keys.")
       (description "@code{xterm-color.el} is an ANSI control sequence to
 text-property translator.")
       (license license:bsd-2))))
+
+(define-public emacs-org-noter
+  (package
+    (name "emacs-org-noter")
+    (version "1.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://stable.melpa.org/packages/org-noter-"
+               version
+               ".el"))
+        (sha256
+          (base32
+            "1hczwva73gsyanl1ldhdvql01gy0hy2g861yzkaklyb763sx58x4"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-org" ,emacs-org)))
+    (home-page
+      "https://github.com/weirdNox/org-noter")
+    (synopsis
+      "Synchronized, Org-mode, document annotator")
+    (description
+      "The idea is to let you create notes that are kept in sync when you
+scroll through the document, but that are external to it - the notes
+themselves live in an Org-mode file.  As such, this leverages the power of
+Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
+acting like notes that are made /in/ the document.")
+    (license license:gpl3+)))